3
$\begingroup$

I have an Anet A8 printer (no modifications) and first printed a calibration cube. It came out okayish, within expectations. Afterwards I flashed the firmware to Marlin 1.1.9 and since then have very high over extrusion. In this picture you see on the left the original calibration cube with the stock firmware and on the right a cube with Marlin (unfortunately not a good picture): enter image description here In fact on the right cube you can see two narrow vertical lines in which extrusion appeared to have come out fine.

The cube on the left was without calibration. On the right hand side all axes, including the extruder, where correctly calibrated. The bed is level. The extruder has been calibrated in case of the cube on the right hand side (95.6 steps/mm). Material is PLA.

After flashing to Marlin the over-extrusion became such a problem that the nozzle is constantly dragging over the printed plastic. You might notice, that these are in fact different cubes, that is correct. I tried the same G-code from the left cube again, but aborted the print, because the nozzle was hitting the print too much.

I calculated a modified flow rate according to this tutorial and found that I would have to reduce my flow rate to 44%.

This appears quite wrong to me. What could be in the firmware change that causes such a massive over extrusion?

$\endgroup$
  • $\begingroup$ Hi Till B, welcome to SE.3D printing! Please update the question to include print material and print settings. Also post steps per millimeters settings of your steppers. $\endgroup$ – 0scar Oct 7 '18 at 15:26
4
$\begingroup$

Very wise to change the firmware of the stock Anet A8. The stock firmware does not have thermal runaway protection which Marlin Firmware does have.

You should be able to print equivalent or slightly better with Marlin Firmware as you can tweak it better/easier than the closed firmware clone of Repetier that is originally loaded onto the board. My A8 runs perfectly fine on 1.1.9.

To identify if this is over-extrusion, you need to check out the settings of the steps per millimeters that are defined in your configuration.h file:

/**
 * Default Axis Steps Per Unit (steps/mm)
 * Override with M92
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
 */
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 100, 100, 400, 100 }

Furthermore, rather than calculating the flow reduction, you could calibrate your extruder.

From the images it it hard to say whether this is over extrusion or not, it does look like it is printed at a high temperature. Please update the question to include print material and print settings (hot end temperature).

| improve this answer | |
$\endgroup$
  • $\begingroup$ I did follow the instructions for calibration that you linked. This is how I came up with the message that I should set the flow to 44% $\endgroup$ – Till B Oct 21 '18 at 14:16
  • $\begingroup$ @TillB About 96 steps does not seem awkward. Please post an image of the used settings of the slicer in your question! Also add if your belts are properly tightened or not? $\endgroup$ – 0scar Oct 21 '18 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.