A z-axis homing issue is giving me an ulcer. I'm hoping someone can help with this.

As per usual, after the Z endstop is triggered on my TEVO Tarantula the gantry raises a bit then slowly lowers back down to the z=0 point established by the trigger. However, the gantry is now lowering well past the point triggered by the endstop. It's forcing the hotend to press down into the bed, and I need to reset the printer to avoid any damage.

I'm at a loss to understand why, and it's making re-leveling the bed impossible. Once I have the bed leveled, an auto home grinds the hotend into the bed.

I've done some cable management in the past couple of days but everything is connected where it should be. The endstops are responding, I've even manually triggered them so I know they're working, but the Z refuses to stop where it should.

I've printed at least once since organizing my cables but the bed wasn't level and then I noticed this issue when homing the Z for re-leveling.

For context, I've had several projects print successfully recently so things had been working fairly well. I haven't made any changes to the Marlin software since originally setting it up months ago. I had been poking around in some settings on the unit but I'm quite sure I reverted everything I tweaked. Regardless, I can't seem to find the menu I had accessed before, and I don't think I've ever had the TEVO successfully save any customizations made via the LCD interface anyway.

  • 1
    $\begingroup$ Welcome to 3D Printing! $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Oct 14 '18 at 22:23
  • 1
    $\begingroup$ I'm honestly unable to tell if that's a genuine welcome to the 3D Printing site, or if that's a "that's 3D printing for ya!" comment. Haha. I think my z-axis woes may be colouring my view so I'll say Thank You! ;) $\endgroup$ – dugost Oct 14 '18 at 23:40
  • 1
    $\begingroup$ It's a definite welcome! We are glad you are here to ask your questions. We are also sorry you're having issues ... hopefully someone will have an answer for you :o) $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Oct 15 '18 at 0:26
  • 1
    $\begingroup$ Have you tried to replace the switch or the cable? Have you tried hooking up a 3D print terminal (e.g. Pronterface, OctoPrint, Repetier) and access the printer over USB. You could then send M503 to get the current settings, please copy them into the question (to prevent endless discussions and information hidden in comments) so others may help you solve your problem! $\endgroup$ – 0scar Oct 15 '18 at 6:45
  • $\begingroup$ Yes, both Repetier Host and Cura (which I use now) is installed on my PC. Fantastic suggestion… which I will follow if the problem crops up again. The behaviour has disappeared on its own and I have no explanation for it. Many, many attempts at levelling before didn't work and then it just worked the next day when I levelled the bed without changing anything, it stopped in the right place. I think I will replace the endstop regardless. $\endgroup$ – dugost Oct 17 '18 at 14:04

The soldering in the Tevo components is very low quality as I replaced/resoldered most of the end-stops.

As the gantry goes down - please ensure that the cable is not pulled over (no contact) and there is contact on the edge of the acrylic and the end-stop, also the small acrylic switch holder could bend/slip a bit. Finally, the sensor connection to the main board could be dragged by wires that are connected to the hot-end.

To validate micro-switch behavior - lift the Z-axis (about 100mm), then set home position and manually trigger the end-stop switch. That shall lift the Z-axis, so then trigger again to see if that works. You will still have a plenty of time to stop the printer if the switch does not work.

If that works, then the reason could be in slipping edge of the black acrylic plate and the micro-switch. Also validate the mechanical connection (if there is a loosening screw (the small on the switch plate)).

  • $\begingroup$ Thanks. The acrylic plate was making contact and fully depressing the micro-switch. All cables and plates were attached and snug. Nothing was getting in the way but I appreciate those troubleshooting tips. I had previously triggered the micro-switch manually and it stopped the gantry from lowering. The issue is that the Z then lowered well past the 0 point established by the trigger. The behaviour has disappeared on its own and I have no explanation for it. Next time I levelled the bed without changing anything it stopped in the right place. $\endgroup$ – dugost Oct 17 '18 at 14:00

I'm not familiar with your particular model, so this may not be directly applicable.

For many printer models, a swing thru thingiverse.com will find you a replacement z-stop switch mount that uses a threaded screw to set the z-height at which the microswitch fires. It may well be that you simply need to offset that height by a few mm to get your first layer to mate well with the print bed.

Here are three examples, albeit for various models. 12488 , 1829747 ,

  • $\begingroup$ a good idea, mine is replaced as well. $\endgroup$ – profesor79 Oct 15 '18 at 20:43
  • $\begingroup$ Agreed, great idea. Thank you! Once I'm back up and running I'll print one for my model. That will definitely make things easier to set in the future. $\endgroup$ – dugost Oct 17 '18 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.