I have a delta printer. The problem is that after the start gcode is executed and the extruder head is 15 (Pic: x0) mm above the center of the plate, the first move towards the start (x1) of the actual print is performed at (maximum possible?) speed @ infinite acceleration. After that the print is performed with regular acceleration. This can cause missing steps.

The problem seems to arise after the start gcode section. How can I fix it. I use Cura 3.5.

enter image description here

Start gcode

G28 ;Home
G1 F1000
G1 Z15.0
G92 E0
G1 F200 E3
G92 E0
  • $\begingroup$ Please post the first part of the sliced file, not only the start g-code script, please show the part up to start printing the product. $\endgroup$
    – 0scar
    Oct 18, 2018 at 20:42

1 Answer 1


By way of comparison, here's what Cura writes as the header of a gcode file. You may want to adjust some of the default parameters in your Cura settings. (this header was same for both the default Prusa and the default Deltabot printer settings)

;Filament used: 22.2173m
;Layer height: 0.06
;Generated with Cura_SteamEngine 3.5.0
M140 S60
M190 S60
M104 S200
M109 S200
M82 ;absolute extrusion mode
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 Z15.0 F9000 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000
;Put printing message on LCD screen
M117 Printing...
G92 E0
G1 F1500 E-6.5

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .