1
$\begingroup$

When I send G1 E5, the extruder motor rotates, but does not stop. It keeps rotating until I restart the system. I am using a Ramps 1.4 board and OctoPrint.

$\endgroup$
  • 1
    $\begingroup$ How many steps per millimeter do you have configured in your Configuration.h file? $\endgroup$ – 0scar Oct 27 '18 at 22:31
  • $\begingroup$ BTW - Welcome to SE 3D Printing! $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Oct 27 '18 at 22:47
  • $\begingroup$ Steps per mm = 200,200,788,200 $\endgroup$ – Mars7272 Oct 29 '18 at 15:15
3
$\begingroup$

If the printer is in absolute positioning mode (which is used almost exclusively), then the extruder will either wind back or wind forward to the last 5mm point. Effectively, the firmware treats the extruder like any other axis, and you can set the origin whenever and wherever you like (it doesn't have to be the home position). Use G92 to reset the extruder position as follows:

G92 E0 ; Set the extruder position to 0 (origin)
G1 E5  ; Extrude 5mm of filament
G92 E0 ; Set the extruder position to 0 again

This is the usual way to purge filament in the slicer's start and end code. Note that you cannot rely on the current position being zero.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you guys. I will check as soon as i get home. $\endgroup$ – Mars7272 Oct 28 '18 at 23:09
  • $\begingroup$ Steps per mm = 200,200,788,200 $\endgroup$ – Mars7272 Oct 29 '18 at 1:45
  • $\begingroup$ I ran G92 E0, G1 E5 and it is still rotating. I changed out the ramps board and the driver... $\endgroup$ – Mars7272 Oct 29 '18 at 1:46
  • $\begingroup$ So... I switched out the stepper motor just to eliminate that variable... Same result. It must be in my firmware. I have reloaded the default I started with months ago... $\endgroup$ – Mars7272 Oct 29 '18 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.