2
$\begingroup$

When I adjust the probe offset to get the proper layer height and adhesion, one side is set right but the other doesn't work. If I decrease the probe offset (say -1.100 to -1.050) the right side seems to print better; if I increase the probe offset (-1.050 to -1.125) the left side will adhere to the plate properly.

Before I added the BLTouch and upgraded the firmware to Marlin 1.1.9 I was able to print a perimeter square (with a little manual adjustment).

My Printer is the Ender 3 and I am using a glass bed and the model is this centre crosshair

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
3
$\begingroup$

I have had exactly the same experiences as you did with a inductive sensor on a Prusa i3 clone. It looks as though the bed leveling is not executed, or the level/mesh tilted. Please do note that automatic bed leveling is not magic, you still need to provide a build platform as level (and flat) as possible. A slate of glass is a good build platform surface as the glass production process ensures that the glass is very flat and easy to level.

What I did to solve the problem is that I re-leveled the bed and send the M420 S1 command over USB to the printer to enable bed leveling as I was under the impression that it did not use the grid obtained with G29.

On my CoreXY I also use a touch sensor (3DTouch, which is a BLTouch clone) like you do, even with that sensor I sometimes see that the automatic level is uneven (one side of the skirt has very thin/see through deposition, while the other side appears normal), this is most probably caused by the sensor accuracy (or an obstruction under the probe needle). There is a way to increase the probing accuracy by using double probing where the second probe is advancing slower to the build platform as can be seen in the Marlin Configuration.h file:

// Feedrate (mm/m) for the first approach when double-probing (MULTIPLE_PROBING == 2)
#define Z_PROBE_SPEED_FAST HOMING_FEEDRATE_Z

// Feedrate (mm/m) for the "accurate" probe of each point
#define Z_PROBE_SPEED_SLOW (Z_PROBE_SPEED_FAST / 2)

For double probing you require to set:

// The number of probes to perform at each point.
//   Set to 2 for a fast/slow probe, using the second probe result.
//   Set to 3 or more for slow probes, averaging the results.
#define MULTIPLE_PROBING 2

Side note:
From an earlier posting it appears that you are using the #define Z_PROBE_OFFSET_FROM_EXTRUDER in the configuration file to set the offset. It is much more convenient to set that through the LCD menu (Bed Leveling -> Z Probe Offset: -–-) or send the M851 Zx.xx directly over USB or load through a .gcode file from SD card to prevent numerous flashing the firmware with alternative parameters. Make sure that you enable:

#define EEPROM_SETTINGS // Enable for M500 and M501 commands

in the Configuration.h file and execute M500 to store the new setting set by M851.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Might want to change the first paragraph to "...build platform as flat as possible" $\endgroup$ – Carl Witthoft Nov 14 '18 at 16:51
  • $\begingroup$ @CarlWitthoft It is intentionally "level as possible", but it also needs to be flat, good point, I'll add that. $\endgroup$ – 0scar Nov 14 '18 at 18:48
  • $\begingroup$ When you say to send a particular gcode command over USB, is that while it is printing the file (and needs to be sent every print?) or while idle (i.e. just after turning on) to turn it on permanently? $\endgroup$ – Liam Nov 15 '18 at 1:03
  • $\begingroup$ @Liam I did this when it was idle and was fiddling with the bed layer level, as you I had one squished side and the other falling down to the plate not adhering and I have no problems with bed adhesion normally as I use 3DLAC and the bare Aluminium plate to print upon, it regularly sticks too well and won't come off unless the plate is cooled down. $\endgroup$ – 0scar Nov 15 '18 at 7:33
  • $\begingroup$ Thanks 0scar, your suggestions have helped massively, there was still small sections where the bed and nozzle came too close but I have fixed it now by adjusting the x-axis crossbar (it was at a very slight angle), it might have been something different but the problem has disappeared during my adjustments of the x axis. $\endgroup$ – Liam Nov 24 '18 at 22:43
0
$\begingroup$

From the looks of your test print, this is unlikely all or only due to levelling unless the glass plate is abnormally uneven. You may have to check your extrusion (speed, temp, feed) parameters and/or adhesion (clean with aceton and/or prepare with hairspray or glue stck)

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.