I recently bought the Anet A8 from Gearbest. Everything so far seems in order, but one big problem.

No matter which filament I used (PLA and ABS), the result is always like this:

Failed print

In the picture there are the PLA and ABS I've been trying to print. What I tried to actually print is a simple arrow.

One of the things that caused it was manually trying to push the filament, because the extruder gear doesn't really push it. It doesn't seem like it's stuck, but it just won't move. Then I move it manually, it does this.

I have tried different methods for the gear to push it and different printing temperatures (first the presets, then PLA 190°C / ABS 240°C) but it does the same thing.

  • 1
    $\begingroup$ Welcome to 3dPrinting.SE! $\endgroup$ Nov 25, 2018 at 0:27
  • $\begingroup$ What temperatures have you tried at the nozzle? $\endgroup$ Nov 25, 2018 at 1:15
  • $\begingroup$ Help us help you! We often need to know extra information, in this case: What is your nozzle temperature and have you leveled your bed? The effect you get is sometimes called "spaghetti" by makers. $\endgroup$
    – Trish
    Nov 25, 2018 at 2:31
  • $\begingroup$ Thank you very much. At first I didn't change the setting of the heat, then tried 190° and 240°. The only thing that showed difference is the smell. As fpr the bed, I didn't touch the setting (And not really sure how and what). $\endgroup$
    – Jeanne
    Nov 25, 2018 at 6:13
  • 1
    $\begingroup$ did you Level the bed? check 3dprinting.stackexchange.com/questions/470/… - you might have jsut too much distance between the print surface and the printhead, resulting in 0 adhesion. To check: home your printer, then order a move of ca 30mm on X and Y and take a picture from the front of the printer with a white backdrop. $\endgroup$
    – Trish
    Nov 25, 2018 at 12:32

1 Answer 1


because the extruder gear doesn't really push it. It doesn't seem like it's stuck, but it just won't move.

It looks like stepper issue.

  • Did you check stepper connections? Maybe there is a loose wire?
  • Maybe your extruder is assembled incorrectly? Please check google images to see how extruder should be assembled and/or give us some photos of your extruder.
  • Maybe your printer is setup wrong, there is small potentiometer on mainboard which sets stepper current, I had problems when it was rotated slightly too far. Try commanding your printer to extrude slowly for several seconds and in this time turn pot at least one time (it wraps around) until it starts to extrude (do not move printhead during this, turning this pot WILL make motors skip and crash into home/end). If you don't have problems with other motors, this may not be your issue but is worth checking.
  • Try homing your axes first, sometimes after startup motors won't work correctly until homing axes.
  • Try pressing reset once after starting printer.

How to find that pot? It's just to the side of capacitor which is near "Z-Motor2" connector.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .