0
$\begingroup$

I have an Anet A8 using the Marlin 1.1.8 Firmware.

There are two (very much related) things that bother me:

G00 Z0 (after auto home from printer menu which places the nozzle at Z10.09 according to my settings) goes to Z5. G00 Z-5 brings the nozzle down to the bed but I cannot see any offset like 5 mm.

In Ultimaker Cura I use the jog buttons (like I always do when leveling the bed) but every time I do this it seems that a Z movement of -5 is added. So I press jog distance 10 to the right. The nozzle goes to the right AND up 5 mm. Same with all other jogs. If I do X movements from the printer menu directly, the printer behaves correctly.

What's new is that whenever I connect or disconnect Ultimaker Cura, the display shows Z-4.99 on the display. I went through all settings even the Marlin configuration.h to check where I could change this but didn't find it.

I am using a sensor as limit switch which pysical distance to the bed is 7.51 mm. M503 tells me that there was an offset (M206) of Z of 5. So I sent M206 Z0. In my firmware (configuration.h) the Z_PROBE_OFFSET_FROM_EXTRUDER is set to 0 ... hmmm, sounds incorrect to me. other z offsets I cannot see being different from 0.

$\endgroup$
  • 2
    $\begingroup$ Hi, and welcome to 3D Printing.SE! We would love to help you out to fix the problem you are experiencing, but at the moment the information is a little terse! Please add what you exactly did to produce this. E.g. are you using the menu, or sending G-codes over USB, what are the codes, moves to 5.0 or 5 up or down, etc. Please help us help you! $\endgroup$ – 0scar Nov 28 '18 at 14:56
  • $\begingroup$ I would like to ask for the following parameters: Physical distance along the Z-axis of the Z-Axis limit switch to the bed. The software offset of the Z-Axis limit switch in your firmware (usually 0). $\endgroup$ – Trish Nov 28 '18 at 16:03
  • $\begingroup$ So, you have a physical 7.51 mm offset into the Z axis? $\endgroup$ – Trish Nov 28 '18 at 17:28
  • $\begingroup$ Why don't you post your configuration file on pastebin or something equivalent and post the link. M206 with Z5 should be Z0, preferably no Z offsets are set in the configuration, you do that afterwards with M851. $\endgroup$ – 0scar Nov 28 '18 at 18:35
  • $\begingroup$ Once you have posted the answer, can you mark it as accepted (using the green tick button) as it will remove your question from the unanswered list, and as we are a beta site, we need to keep the unanswered queue to a minimum. Thanks again. $\endgroup$ – Greenonline Feb 18 at 16:30
2
$\begingroup$

Answer taken from OP's question


(24.01.2019) UPDATE: I updated Marlin to 1.1.9 and used the configuration from repository. Since I also printed a new print head (for Bowden extruder) I had to rework all offsets. Same time I switched to Simplify3D (cause I need better control for support blocks). Since then the problem disappeared (not surprised). I could not figure out what setting caused my problem. Thank you!

$\endgroup$
  • $\begingroup$ @Mirco - If you care to submit your own actual answer, I will delete this Wiki answer, thanks. $\endgroup$ – Greenonline Apr 14 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.