I am having an issue where several prints I downloaded from thingiverse causing my printer to freeze in the first minute of the print. The print head stops, pushes out a small amount of PLA and then does nothing. The control board continues to show the print progress bar continuing.

One thing that could be possible is I am using the wrong G-code flavor. I am running Cura 3.4.1 and I set the printer to use RepRap. I also tried Marlin. Which one of those is right for my printer? Could it be something else?

My MonoPrice printer firmware version is v35.110.2. The item I tried to print has the gcode from this page. https://www.thingiverse.com/thing:2221657.

  • 1
    You should be using Marlin, Reprap is a little different, it uses relative extruder movement from what I can see. Have you updated the firmware recently? Could you add more information. Link to the G-code and to the model? – 0scar Nov 30 at 7:36
  • I will add all of that info this weekend. I have not updated the firmware since I purchased it. I know when I bought it in November of last year it had the latest firmware. I had a similar issue about 8 months ago with another model and I eventually gave up on it. – Ben Hoffman Nov 30 at 12:08
  • @0scar I updated my question with the printer firmware version and a link to the source file. How should I attached the .gcode file. I can add a dropbox link or is there some gcode specific site that works best for sharing? Thank you! – Ben Hoffman Dec 3 at 1:01
  • You could share it over dropbox, but pasting the file on pastebin should also work. – 0scar Dec 3 at 6:07

If you go to the Monoprice website you will find a dedicated page for Ultimaker Cura.

From the page you can read that:

Cura now includes profiles for the MP Select Mini V1 and V2. Go to “Settings”, “Printer”, “Add Printer…”, “Other”. Select the radio button next to the printer, then “Add Printer”.

So you must be able to configure it correctly for your printer (this must include the G-code flavor for your printer). Do note that Monoprice does nothing with the Ultimaker Cura installers, they simply link directly to the source at Ultimaker. Also note all the problems related to specific versions and how to fix them.

You write that the:

The control board continues to show the print progress bar continuing.

This I have experiences myself (on a different printer with Marlin 1.1.8), so a non-printing printer while the progressbar progresses. I solved this myself by flashing to a newer firmware version. It appears to be a bug in the firmware.

You might want to explore whether it is feasible for you to update, I read that there are issues with this printer concerning firmware updating (it appears that there are different hardware versions of this printer).

E.g. from this reference:

  • If your MPSM V2 currently has Motion Controller v34 or higher installed then you can update with this firmware.
  • If your MPSM V2 currently has Motion Controller v30 or lower, do NOT update with this firmware.
  • If you have Motion Controller versions 31, 32, or 33 please ask before updating with this firmware.

Although the changelog does not mention your problems, you may benefit from a firmware update. Please do this at your own risk, take precautions and read in the matter if your printer is able to be updated. It is best to first look into your settings how the printer is configured in Ultimaker Cura. Preferably, delete the current printer configuration and add a new configuration as described here.

The source of the files (thingiverse) is irrelevant -- what matters is what the slicing software creates for gcode. Since you're using Cura,go to monoprice for their advice.

There are a number of Cura + monoprice instructional vids on youtube as well.

not to mention several reddit channels.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.