3
$\begingroup$

My Prusa i3 MK3 forgot his home position and it now assumes that the Z 0.0 position is right at the top of the printer. I've asked about this in the Prusa forum before and at that time, I accidentally found a solution using Pronterface.

So I am now in the same situation again. The printer head is at the very top. It assumes that this is Z 0.0, so I can't move it down.

Calibrating Z does not help. It will always display

Some problem encounteres, Z-leveling enforced ...

and some time later, it calibrates Z again, resulting in the same problem and so on (endless loop).

The Pronterface trick (pressing the home button) does not work any more. However, Pronterface seems to accept raw G-Code.

Which G-Code command would I need to send to the printer to let the head move down? That would need to be a command that just rotates the stepper motor and does not consider the Z-axis value, so that the head effectively moves to negative Z values.

I have also tried:

  • moving the head down manually while the printer was turned off. I'd like to avoid that. It just doesn't feel right. However, it worked after the third attempt and I was able to do a XYZ calibration. However, during bed leveling, it failed and went into the "some problem encountered" state again.
$\endgroup$
1
$\begingroup$

To allow negative axis values, usually, the way is to use G1 S1 to disable boundary checks and G1 S0 to enable them.

Another way is to force homing Z, which means moving till an endstop triggers and then moving back up the specified motion via G28 Z

Another alternative would be to send G92 Z50 to set the Z-hight to 50, then G1 Z-50 F200 to move that much down, rinse and repeat.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.