1
$\begingroup$

I'm trying to do my first ever print with my Geeetech prusa i3 pro.

When I try to print that printer seems to work, x,y,z axis all moving ok.

What isn't working is that little to no plastic is being extruded.

The nozzle appears to be getting to temperature, and some plastic comes out whilst it's heating, but then when it starts to move and print, no plastic comes out.

My thoughts are:

  1. Have I not loaded the plastic properly
  2. Is the extruder engine not working i.e. not pulling the plastic through

Any hints on what I can try would be appreciated.

$\endgroup$
  • 1
    $\begingroup$ What did you do to troubleshoot already? What exactly does not happen? Do the Gears turn or not? Is the motor connected? $\endgroup$ – Trish Dec 20 '18 at 12:10
  • $\begingroup$ I've wired the motor in as per the build instructions. How would I know if the gears are turning are they not internal ? I suspect this is the case - it does not look like it is feeding the filament in at all. $\endgroup$ – Andrew Marsden Dec 20 '18 at 12:21
  • $\begingroup$ There is exactly 1 gear on the extruder stepper motor: the one that tries to push the filament. As a good test, remove the filament. $\endgroup$ – Trish Dec 20 '18 at 12:30
  • $\begingroup$ OK, I've removed the fan and heatsink so I can get a better view of what is going on. Using the repetier-host I'm trying to drive the extruder motor - but I'm getting no movement. If I've wired it in correctly (and I think I have) does this imply an issue with the motor itself ? $\endgroup$ – Andrew Marsden Dec 20 '18 at 14:10
  • $\begingroup$ Is the extruder gear turning into the right direction? $\endgroup$ – dgrat Dec 20 '18 at 14:10
2
$\begingroup$

Problem identified.

I took of the fan and heat sink so I could see what was going on in the mechanism that should pull through the filament.

Using repetier-host software I tried to manually drive the motor - nothing happening.

I swapped the A4988 stepper motor driver for the extruder with another (and my x,y,z axis motors work) to see what would happen - and it worked!

So just a faulty A4988 on the extruder motor.

I also manually pushed filament through the hot end to ensure there was no blockage and it worked fine.

So hopefully GEEETECH can send me a replacement and I'm good to go!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.