3
$\begingroup$

I am using Ultimaker Cura to try and get my simple metal back up and running again. It is the strangest thing as this thing has printed decently for four years with just one calibration being the initial calibration without needing adjustments. I moved recently and the printer has been stored for almost a year. I plug in and updated Ultimaker Cura and then found out the printer won't connect just through Ultimaker Cura anymore and I would need something called Pronterface. I followed instructions from a different printer forum and then encounter that the printer won't connect to Pronterface either. Both with same error message reading.

Error message reads in Pronterface as:

[ERROR] Could not connect to COM3 at baudrate 250000:
Serial error: could not open port 'COM3': WindowsError(5, 'Access is denied.')

I have already checked the ports in device manager and see the the printer is in COM3 and I have tried all Baud rates including 115200 and 250000 and 96000, and the hard reset button next to the connect button three times trick and still the same error message nothing will work. Please help.

$\endgroup$
  • $\begingroup$ Welcome to 3DPrinting.SE! $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Dec 23 '18 at 18:00
  • 1
    $\begingroup$ Two questions: 1) Are you sure you're on the right COM port? 2) I don't see as where you've tired 115,200 baud rate. This is the rate at which I had success. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Dec 23 '18 at 18:07
  • $\begingroup$ Try a different COM port, my Mega 2560 refuses to connect to ports at the front of the computer, but works with the ones on the back. This has to do with powering of the ports. $\endgroup$ – 0scar Dec 26 '18 at 7:52
  • $\begingroup$ I have tried ALL COM ports and ALL baud rates. Access is still denied with same error message. $\endgroup$ – Grant Jan 1 '19 at 17:47
  • $\begingroup$ Did you close Cura when attempting this? Cura seems to block all access to all COM ports whenever it's open, regardless of whether it's actually connecting to them or not. $\endgroup$ – towe Nov 15 '19 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.