5
$\begingroup$

So, the wife got me a Creality Ender-3 Pro 3d Printer for Christmas.

Assembly was easy, axis movements are all solid... when I go to print the test-dog.gcode file provided with the machine, it comes out looking... flat.

Not kind of flat. TOTALLY flat.

The Z-Axis motor works - I can move it with the machine's control panel - and it moves on it's own for repositioning of the head for printing purposes, but it doesn't seem to be moving 'up' for each new layer. Layer height is set for 0.1 mm, nozzle is .4 mm. No settings changed in the G-code, or on the machine (and I did a "reset to failsafe" before attempting to print anything).

I'm relatively new to additive manufacturing, can someone help out here?

Photo of the test print

$\endgroup$
  • $\begingroup$ I always shiver when G-code files are distributed for printing, I'd rather be in control myself. Have you looked into the G-code file? There should be codes like G1 Z x.xx, where x.xx denotes a value. If you see Z increasing in the file, the file could be okay, but I'd rather see you slice it yourself. Does the machine home correctly? $\endgroup$ – 0scar Dec 29 '18 at 20:45
  • $\begingroup$ Your first layer appears to not adhere too well, it looks as though the lower right corner of the bed is lower than the other corners. Please re-level the bed, slice a calibration cube yourself and post the result. It is far easier for others to help you based on a simple print rather then a complex object none or few of us printed. $\endgroup$ – 0scar Dec 30 '18 at 19:21
  • $\begingroup$ "It is far easier for others to help you based on a simple print rather then a complex object none or few of us printed." Thanks Oscar, but the issue was that the original gcode file distributed with the printer wasn't printing anything other than on a single layer. $\endgroup$ – Darryl Hadfield Dec 30 '18 at 21:06
  • $\begingroup$ Exactly why I posted the comments to help you figure it out yourself, good job! Keep the questions coming! $\endgroup$ – 0scar Dec 30 '18 at 21:57
1
$\begingroup$

It turned out that there's something wrong with the G-code file that came with my printer.

I downloaded a calibration cube from Thingiverse and printed it - while it wasn't 100%, it did print viable. Now I need to get into details as to quality, and I suspect that too will be a factor for the G-code used in the printer. I'm looking at "Ultimaker Cura" to figure out the changes in G-code based on option changes.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ You're welcome :), Ultimaker Cura is not that difficult, there is a simple mode and an advanced mode. Just Google a bit and if you have questions, don't hesitate to ask them. $\endgroup$ – 0scar Dec 30 '18 at 21:53
  • $\begingroup$ most of the quality issiues can be fixed with cura - show us your cube and we can help you fix it up. They must have changed the g-code between your and my distriburtion - mine rinted perfectly. $\endgroup$ – Trish Dec 30 '18 at 21:54
0
$\begingroup$

Check the following:

  • Is the lead screw bent? remove it from the assembly and have it roll down a very slightly angled plate - if it rolls at uneven speed, it is bent.
  • are the motor perfectly aligned with the brass nut? The lead screw needs to slot into the coupling without any force or need to move it just from gravity alone.
  • is the Z-axis nut spin easily? I gave mine a droplet or two of machine oil, motor it up and down the whole length twice. Some residue grease from the factory can bind up the motor.

If all the physical side is known to be OK: re-slice your object, you might have faulty g-code.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ No, the lead screw is not bent. Per my original post, "Z-Axis motor works - I can move it with the machine's control panel - and it moves on it's own for repositioning of the head for printing purposes" No, the motor isn't 'perfectly' aligned however, it's close enough that z-axis movement is viable. I addressed this in my first post, again, see above. "Z-axis nut spin easily" Do you mean the z-axis screw guide? Yes, the screw spins through that. $\endgroup$ – Darryl Hadfield Dec 30 '18 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.