I dont want the part cooling fan on during preheat, especially when I'm only heating the bed, it is just unnecessarily loud and serves no purpose at that time.

However when I set PREHEAT_1_FAN_SPEED to 0 it has no effect, the fan still spins at full speed as soon as I preheat either the hotend or the bed.

So why is this setting not working and how do I fix this?

I am using the latest version of Marlin.

The only one that is defined is the one that I am editing and it is the one that appears on line ~1260 of the stock configuration.h

#define PREHEAT_1_FAN_SPEED 0 // Value from 0 to 255

And this is the grep result of searching the entire firmware folder:

grep results

  • 1
    $\begingroup$ This question is a little terse and could use some extra information, please update the question by edit to include where you set this constant (as it could be that it is overridden later!). The default Marlin configuration.h file already contains a PREHEAT_1_FAN_SPEED of zero, part cooling fans should therefore never spin unless the configuration is altered. In that effect, which sources do you use? Original Marlin sources or a repository of someone else? $\endgroup$
    – 0scar
    Jan 2 '19 at 7:55

Apparently, I forgot a critical step:

While I have completely reconfigured the LCD menus, setup custom 25-point mesh leveling, changed a bunch of other numerical values, and flashed the firmware dozens of times, certain values will never be updated unless you remember to initialize the EEPROM after the flash!

Honestly I kinda wish they would make it all or nothing but I guess there is limited space so particular things take priority.


This answer is now obsolete now that the OP has updated the question with additional information. It is left here as a possible solution for those who have tinkered with there firmware.

Part cooling fan speed during preheat (from menu) is controlled by the setting

#define PREHEAT_1_FAN_SPEED     0 // Value from 0 to 255

in Configuration.h where a value of 0 implies no rotation, or 0 % and 255 implies 100 %.

If changing this value in your configuration does not result in a reduced fan speed, you could have this constant be defined somewhere else overriding this value.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.