I can launch Cura with no issues, it runs fine. I can import objects and change settings, but when I click 'slice' it doesn't even show a progress bar on 3.6.0 and on v4 it shows a progress bar but there's never any progress. I've looked in %appdata%\cura\4.0\cura.log and it just stops at an entry like this:

2019-01-11 20:38:46,714 - DEBUG - [MainThread] CuraEngineBackend.CuraEngineBackend._onStartSliceCompleted [430]: Sending slice message took 0.7397589683532715 seconds

I looked in task manager and the system idle process has >95% cpu (cpu is almost completely idle), and like I said I can use Cura just fine (no stuttering when I rotate objects).


1 Answer 1


The culprit was ZoneAlarm firewall. Cura runs and talks to another executable (CuraEngine.exe) for slicing, and ZoneAlarm never asked me whether CuraEngine should have the access it needed, so it got blocked.

Here are the steps I took to fix it:

  1. Open ZoneAlarm
  2. click the firewall tab
  3. click where it says "X programs secured"
  4. under "View Programs" you'll see a bunch of program names. It takes a while for my list to populate, you may have to wait a minute here.
  5. Find the entry for cura.exe (you can order them by alpha) and set "Outbound Trusted" to Allow
  6. Find the entry for "Slicing engine for Cura" (that's how CuraEngine.exe is listed). Set "Outbound Internet" to "Allow" and set "Inbound Trusted" to "Allow" (this will implicitly set "Outbound Trusted" to "Allow" as well).
  7. Click "OK"

You should be good to go. I didn't even have to restart Cura. I just hit 'cancel' on that slice and then clicked 'slice' again and it worked.

From my testing, the settings in 5. and 6. are the minimum you can allow and still get it to work.

  • $\begingroup$ Welcome at 3D Printing.SE! Thanks for sharing your experience, I have struggled many times to find a similar solution for other applications that call executables instead of dll files. The actual slicing is indeed done by the engine of Ultimaker Cura, a separate executable. $\endgroup$
    – 0scar
    Jan 12, 2019 at 11:50
  • $\begingroup$ Sounds like another app never to install in the first place. BTW, your name seems to conflict with your current OS :-) . $\endgroup$ Jan 15, 2019 at 15:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .