3
$\begingroup$

I got things moving from the answer to a previous question. Now, since the base-video I'm following is non-English, I want the next phase fixed: Probing failed

Auto Homing showing failing Z-homing

ProbeErrorLCD

After the final adjusted firmware upload, and bringing the sensor up, I see that the extruder pushes the bed down a bit when I auto home and then the LCD screen says probing failed.

If compare to the latest (v1.1.9) Configuration.h file from GitHub, here are the changes:

#define FIX_MOUNTED_PROBE // Line #0719, Uncommented

#define X_PROBE_OFFSET_FROM_EXTRUDER 16  // Line # 0779, Was 0
#define Y_PROBE_OFFSET_FROM_EXTRUDER 58  // Line # 0780, Was 0

#define Z_HOMING_HEIGHT 5 // Line # 0870, Was 4  

// #define MIN_SOFTWARE_ENDSTOP_Z // Line # 0907 Commented

#define AUTO_BED_LEVELING_LINEAR // Line # 0977, Uncommented

#define LEFT_PROBE_BED_POSITION  (X_PROBE_OFFSET_FROM_EXTRUDER + MIN_PROBE_EDGE) // Line # 1027, Uncommented
#define RIGHT_PROBE_BED_POSITION (X_BED_SIZE                   - MIN_PROBE_EDGE) // Line # 1028, Uncommented
#define FRONT_PROBE_BED_POSITION (Y_PROBE_OFFSET_FROM_EXTRUDER + MIN_PROBE_EDGE) // Line # 1029, Uncommented
#define BACK_PROBE_BED_POSITION  (Y_BED_SIZE                   - MIN_PROBE_EDGE) // Line # 1030, Uncommented

#define Z_SAFE_HOMING // Line # 1144, Uncommented

From the above changeset, lines 1027-1030 are from the other SO question I mentioned above, the remaining are following the video.

After completing the steps up to the point where I push the firmware and have to lift the ROKO up I followed instructions in this video, my "Auto Home" operation is failing.

Update 1

I used Pronterface as recommended by @dgrat in comments below and got this result:

>>> M119
SENDING:M119
Reporting endstop status
x_min: open
y_min: open
z_min: TRIGGERED

I did not get the Probing failed message this time.

What's next?

Update 2

I also went ahead and tried out the second answer, where @0scar is recommending to uncomment #define MIN_SOFTWARE_ENDSTOP_Z.

The results are exactly the same: The head hits the hotbed and goes back and then comes down slowly hitting and compressing the spring a bit before stopping. I did not get the Probing failed message this time.

$\endgroup$
  • 1
    $\begingroup$ Does the endstop trigger? $\endgroup$ – dgrat Jan 30 '19 at 11:37
  • $\begingroup$ @dgrat How do I detect that trigger? $\endgroup$ – Hassan Gulzar Jan 30 '19 at 11:41
  • 2
    $\begingroup$ There is a command for that. marlinfw.org/docs/gcode/M119.html. I use it now and then with pronterface.com. You are not the first one with such problems. I suggest to always test the switches before using the machine to avoid damage. $\endgroup$ – dgrat Jan 30 '19 at 12:11
  • $\begingroup$ @dgrat please check update to thread $\endgroup$ – Hassan Gulzar Feb 23 '19 at 10:09
  • $\begingroup$ I also tested that raising the z-axis by just 2 nm makes the A4 paper on the bed move with an acceptable resistance. Have I hardcoded the Z position somehow? $\endgroup$ – Hassan Gulzar Feb 23 '19 at 10:48
1
$\begingroup$

You should un-comment the following line to get rid of the Probing failed error message:

// #define MIN_SOFTWARE_ENDSTOP_Z // Line # 0907 Commented

to

#define MIN_SOFTWARE_ENDSTOP_Z

You have basically disabled the use of the minimum Z endstop, while in fact you are using one, the difference is that it is a sensor now, not a mechanical switch.

Please note the distance of the sensor to the bed, it looks as though it is pretty far away. Before sending an auto home command, it is better to test the endstop triggering beforehand; an external application (e.g. Pronterface, Repetier-Host, OctoPrint, etc.), USB cable and a laptop/computer can be used to send G-code commands through the terminal of the external application. Code M119 will output the endstop trigger status to the terminal.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I'll make this change and push firmware again. Will get back on this. I do not know why the guy in the video commented this out. $\endgroup$ – Hassan Gulzar Jan 31 '19 at 3:47
  • $\begingroup$ @HassanGulzar Have you fixed this, if not update your question so that other people may answer, or an update can be made. $\endgroup$ – 0scar Feb 8 '19 at 15:47
  • $\begingroup$ Not yet. I have to redo the setup to verify if I've done anything wrong $\endgroup$ – Hassan Gulzar Feb 8 '19 at 15:48
  • $\begingroup$ I tried with the line uncommented but the result is the same. The head still pushed down on the hot plate such that the springs are a bit compressed. $\endgroup$ – Hassan Gulzar Feb 23 '19 at 10:31
  • $\begingroup$ @HassanGulzar As far as can be seen the configuration is fine, to be sure add a link to your configuration.h file. What you describe now is that it works correctly, but it is not tuned correctly. $\endgroup$ – 0scar Feb 24 '19 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.