3
$\begingroup$

Flsun 3D Cube; Marlin 1.1.1; main board: Makerbase MKS Gen_L V1.0; running from either Repetier or OctoPrint.

I was recently obliged to replace the main board when it stopped powering the heated bed. I got the new main board - same make, version, etc - got everything setup just as it was before, but the bed still doesn't heat. Multimeter shows zero across the board's heat bed contacts, whether using G-code from the terminal (in both Repetier and Octoprint), G-code in the print file, or the control panel on the front of the printer. The thermistor works: if I shine a heat lamp on the bed, it registers the temp change.

Bad board? Something in the Merlin config I missed? Is the board smart enough to not power it on if the bed heater itself is bad?

| improve this question | | | | |
$\endgroup$
  • 2
    $\begingroup$ Welcome to 3dPrinting.SE! You state "Marlin 1.1.1" ... is that correct? Marlin 1.1.9 is the most current stable version. You might try loading it and seeing if the issue still exists. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Feb 13 '19 at 17:52
  • $\begingroup$ One of the prime rules of problem-solving: don't assume a cause. In this case, that means don't replace a board until you know it is actually the reason you're not heating. $\endgroup$ – Carl Witthoft Feb 14 '19 at 14:13
  • $\begingroup$ Do any other outputs (e.g. xyz drives) work? $\endgroup$ – Carl Witthoft Feb 14 '19 at 14:14
  • $\begingroup$ @CarlWitthoft 1. Good advice for any situation. Not replacing the board (in other words: spending more money) until I'm sure. 2. All other outputs work: the printer functions normally otherwise. My prints are curling on the corners, so I am motivated to fix the bed. $\endgroup$ – Bill in Kansas City Feb 14 '19 at 19:15
2
$\begingroup$

Considering:

Multimeter shows zero across the board's heat bed contacts

this implies that

  • If you measured resistance, the heated bed has no resistance. Basically this implies that the bed has a short. This might be the reason why it is not working. If you would power it as such you create a short. Instead of replacing the board, you need to replace the heated bed. Typical values for a heated bed of about 200 x 200 mm are in the order of 1.2 Ω (measurements between 0.9 and 1.5 Ω are reasonable to be expected).
  • If you measured voltage, the heated bed does not receive power for heating, or the power does not reach the bed (not turned on or broken wire?). It would then be wise to measure the resistance (of the bed and the wires). If the resistance is in the order of about 1.2 Ω (see above) for the bed, you could try to connect the heated bed directly to the PSU to see if it gets warm, if so, please disconnect immediately to prevent damage. From this experiment you can find whether the heated bed is broken (or the cables), or that the board is not functioning correctly, this is, however, strange as you tried 2 boards. A possible suspect could be the MOSFET that schedules the powering of the heated bed if you use an external MOSFET board that it.
  • If you measured current, then you found out that no power is delivered to the board, but you also might have broken your board in the process, as measuring current is a (close to) 0 Ω connection and has to be done in line of a circuit.
| improve this answer | | | | |
$\endgroup$
  • 2
    $\begingroup$ Perhaps the multimeter was in voltage measuring mode. The question doesn't say they were measuring resistance. $\endgroup$ – Tom van der Zanden Feb 14 '19 at 9:35
  • $\begingroup$ @TomvanderZanden Good point! Updated the answer to include both. $\endgroup$ – 0scar Feb 14 '19 at 10:05
  • 1
    $\begingroup$ But it's unlikely the same MOSFET would be bad on both boards (if the power MOSFET isn't on the board he replaced, then ignore this comment) $\endgroup$ – Carl Witthoft Feb 14 '19 at 14:13
  • $\begingroup$ @CarlWitthoft The question does not state the use of an external MOSFET, good to make that clear $\endgroup$ – 0scar Feb 14 '19 at 14:35
  • $\begingroup$ 1: The MKS GenL is a purpose-built board, nothing external. 2: With the bed (supposedly) heating (issued M140 S60, response OK), I measured DC voltage on the board's heated bed connector, as shown in this image: postimg.cc/jD5Sbhtj $\endgroup$ – Bill in Kansas City Feb 14 '19 at 19:13
0
$\begingroup$

Since the bed was warm when you connected to 12 V that means the bed and the wiring are good. It sounds like your multimeter is not too accurate, with a reading of 0.5 Ω (or you measured accidentally some other circuit), but no worries.

Since both boards do not power the bed, it seems like it could be a firmware setting. To help with that, a look at your config file, and possibly the pins_ramps.h file can help.

As a first check, your mks_gen_L.h file should look like this;

    #if HOTENDS > 2 || E_STEPPERS > 2
  #error "MKS GEN L supports up to 2 hotends / E-steppers. Comment out this line to continue."
#endif

#define BOARD_NAME "MKS GEN L"

//
// Heaters / Fans
//
// Power outputs EFBF or EFBE
#define MOSFET_D_PIN 7

//
// CS Pins wired to avoid conflict with the LCD
// See https://www.thingiverse.com/asset:66604
//

#ifndef X_CS_PIN
  #define X_CS_PIN 59
#endif

#ifndef Y_CS_PIN
  #define Y_CS_PIN 63
#endif

#include "pins_RAMPS.h"

Now all you need to confirm is that your bed is hooked to D7.

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ the main part is good, but I have experienced a lot of people just having problems how to measure the resistance correctly. $\endgroup$ – Trish Feb 26 '19 at 14:11
  • $\begingroup$ @yellow I'm grateful for the firmware comment: when I upgrade to the latest version of Marlin (in about a week when I get new stepper drivers; I'm going to do everything at once) I may well have to know that. However, the original board WAS powering the bed, and then stopped; I can see on the board where the connection failed. At the time it was still running the original firmware, and no other changes had been made. $\endgroup$ – Bill in Kansas City Feb 26 '19 at 16:23
  • $\begingroup$ @Trish This is quite likely. I'm currently attending the University of Google, and the class content isn't always clear. "A Beginner's Guide To..." articles are rarely vetted by actual beginners. $\endgroup$ – Bill in Kansas City Feb 26 '19 at 16:23
  • $\begingroup$ @BillinKansasCity how about having a talk about that in 3D Printing Chat? $\endgroup$ – Trish Feb 26 '19 at 16:59
  • $\begingroup$ @Trish At your convenience. I'm back at my desk and available. $\endgroup$ – Bill in Kansas City Feb 26 '19 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.