4
$\begingroup$

When double-probing, sometimes the BLTouch will hit the bed before the z-axis goes down:

  1. The BLTouch deploys
  2. The bed goes up
  3. The sensor triggers
  4. The BLTouch stows
  5. The BLTouch deploys and crashes the bed before the z-axis goes down for the second probe

It happens only on the second probe of double-probing (slow speed) - the bed can't move out of the way fast enough. This happens in 2/16 probe points.

Probe Accuracy Test result:

  • Mean: 0.023075 mm
  • Min: 0.018 mm
  • Max: 0.027 mm
  • Range: 0.008 mm
  • Standard Deviation: 0.002584 mm
$\endgroup$
2
  • $\begingroup$ Hello David, I noticed your question has been up for a while now. Have any of the answers below been able to solve your question? If so, would you mind accepting the appropriate answer. If not, what is missing so that we may help you further? Also, if you have figured it out on your own, you can always answer and accept (after 48 hours) your own solution. Thank you! $\endgroup$
    – 0scar
    Oct 27, 2020 at 9:09
  • $\begingroup$ Sounds like the height the printer is supposed to go to before second probe is too low. $\endgroup$
    – Justin
    Aug 5, 2021 at 17:18

4 Answers 4

1
$\begingroup$

First, make sure to check if stow, deploy and the trigger are working correctly.

Second, check the pins files to make sure you put it in the correct pins. Black and White probe pin might need to go to Z-min or probe pin depending on. Make sure to check that.

Third, add "BLTOUCH delay". It might be triggering too slow or too fast for the next one to react. So after the first trigger, there should be a time for it to "re-setup" for the second. But if there is no time to do that then it won't trigger.

To add examples: If you have SKR 1.4 Turbo, then use BLTouch probe pins (black and white) on the board. IT will NOT recognize. You have to use Z-min endstop pins. Reason for this?:

#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

If this has been used, Z-min probe will use Z-min endstop pin instead of Z-min probe.

$\endgroup$
1
$\begingroup$

In case someone still has this problem I have a solution for what happened in my case.

I am using a 3DTouch and I also encountered the same problem and it was solved by commenting //#define BLTOUCH_HS_MODE

$\endgroup$
2
  • $\begingroup$ The High Speed mode is not recommended, so indeed this line must be commented out. $\endgroup$
    – 0scar
    Nov 3, 2020 at 15:21
  • $\begingroup$ Welcome, and please take the tour. $\endgroup$
    – Davo
    Nov 3, 2020 at 19:12
1
$\begingroup$

I solved the same issue.

I had the same problem, just send the G-code M502 to your printer through Cura or whatever it is you use. The reason is that you already did an auto bed leveling and you more than likely send the G-code M500 which saves your auto mesh data so that you don't have to auto home for every print.

So M502 restores everything to its factory settings after you reset don't forget to send M500 to save the default settings or else your printer will be fixed up until the next time you turn it on and you'll have to start all over again hope this helps.

$\endgroup$
0
0
$\begingroup$

This sounds like the firmware setting for your BLtouch is not set up properly. Look at the line in Config H where it deploys the BLtouch. make sure nothing is commented out and that the 2nd deploy is shown.

$\endgroup$
3
  • 2
    $\begingroup$ "2nd deploy is shown", Can you be a bit more specific about this? $\endgroup$ Mar 1, 2019 at 0:42
  • 1
    $\begingroup$ Could you expand upon your answer please? $\endgroup$
    – Greenonline
    Apr 14, 2019 at 9:54
  • $\begingroup$ If the 2nd Deploy is shown on the line make sure that line is not commented out. Remove the "#" in front of the 2nd Deploy to activate that line. $\endgroup$ Apr 15, 2019 at 12:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .