7
$\begingroup$

I've been using my Ender 3 for about four months now and it's been working wonderfully. The print quality is amazing and all the prints are very strong. Then about three weeks ago, my entire system crashed while Ultimaker Cura was open and it lost the profile for my 3D printer. I recreated the profile to the best of my ability with other people's working profiles online, but none of them worked right. I've been getting severe under extrusion in all my prints, and they're incredibly fragile. For now, I've just been printing a 1"x1"x1" test cube. I've tried many steps from other people's posts online to fix the problem, including:

  1. Raising the print temperature for PLA to 200 °C.

  2. Checking the extruder for signs of too little tension or too much tension. I checked, and the PLA has light tooth imprints on it, and no grinding or damage to the filament.

  3. Clearing out the extruder. I disassembled the whole extruder assemble, and flushed all the plastic from each part with a heat gun, and metal pick, and then tried reprinting, but it didn't work.

  4. Trying a newer Ultimaker Cura version. At the time, I was using Ultimaker Cura 3.1 and hadn't updated because it was working well. I then tried the newest stable release of Ultimaker Cura 3.6, with a few different profiles, and then I also tried the beta version of Ultimaker Cura 4.0, but none of these worked.

  5. Increasing the extrusion rate. I incrementally increased the extrusion rate from 100 % all the way up to 130 %. The prints looked a little better and were a lot stronger, but this still didn't fix it.

  6. Trying a different slicer. I then downloaded Slic3r and created a new profile in that. The prints turned out a lot better, but there was still significant under extruding.

  7. Checking the filament tube for any burns or damage, and ensuring it's inside the extruder assembly all the way.

If anyone can help me figure out what's going on with my printer, I'd really appreciate it!

Here are some pictures of the prints I've been getting: These were made in Ultimaker Cura with different small changes to the profile made

Ultimaker Cura Settings Under Extrusion

These were made in slic3r with a flow rate adjusted up to 130% Slic3r Under Extrusion

These were prints I made before I lost all my settings in Ultimaker Cura. Good Prints

Here's some of the material I read/watched and checked before posting myself:

Edit: Here's my printer profile: Ender 3 Profile Google Drive

$\endgroup$
  • $\begingroup$ Hi Tinkerman255 and welcome to the 3D Printing.SE! I don't want to rude, but your "good prints" are not that well either. Are you sure it isn't an issue that progressed over time or over the crash? Please do check the filament diameter setting, it fooled me countless times when I changed to a newer Ultimaker Cura version and use both 2.85 mm as 1.75 mm filament intermittently. $\endgroup$ – 0scar Mar 11 '19 at 7:34
  • $\begingroup$ I agree with you that the print quality before the crash wasn't the greatest. However, it was very consistent and strong, so I had no complaints. It printed with that quality since the time I got it, so I'm confident it isn't an issue with the hardware. As for the filament diameter, I made sure it's all set correctly, and that hasn't helped either $\endgroup$ – Tinkerman255 Mar 11 '19 at 16:21
6
$\begingroup$

It is not too rare to create a new machine in Ultimaker Cura to be set to 2.85 mm as this is the default. Also some bugs in the past did reset or assume this diameter unless you manually set it, and unless we know your exact version we can't confirm it is really this.

Underextrusion why?

The 0.55 mm more radius result in an underextrusion due to the pressed through volume, and since $V=A\times l$, we need to see the area to see how severe the underextrusion is for one given extruded length. $A_{1.75}=2.405\text{ mm²}$ and $A_{2.85}=6.379\text{ mm²}$ are rather obvious, so $\frac {\text{real extrusion diameter}} {\text{calculated extrusion diameter}}=\frac{A_{1.75}}{A_{2.85}}=37.7\ \%$, so only about 40 % of the needed filament is pressed through the nozzle as the slicer thinks it is almost twice the diameter. This matches well with the 130% still being very spotty, as that'd need a much higher factor to compensate for the underextrusion. A compensating extrusion multiplier would be $\frac 1 {0.377}=265.25\ \%$.

Fixing

To fix this, check under filament and set it to 1.75 mm so you force the correct diameter. Remember that filament diameter is not saved in the printer profile but in the material database.

You might need to restart Ultimaker Cura to activate these new settings.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Agreed. It's a classic Cura gotcha. $\endgroup$ – Mick Mar 10 '19 at 23:30
  • $\begingroup$ I created a new printer profile and made sure the filament diameter was set to 1.75". I then made sure the material was set to PLA 1.75". I'm still getting severe under extrusion. Here's my current settings: drive.google.com/file/d/10_HiEnVGtU1GS1N-Scy-6KG363BIa31d/… $\endgroup$ – Tinkerman255 Mar 11 '19 at 15:59
  • $\begingroup$ None of the settings in this file, or the one on the question, have anything to do with filament diameter. $\endgroup$ – Joel Coehoorn Mar 11 '19 at 19:23
  • 1
    $\begingroup$ Finally, there was a bug in Cura where it would ignore your filament setting if you did not have a specific material selected, and revert the default 2.85. I believe this was fixed, but not knowing what version of Cura you have, make sure you actually select a material, and the filament size is set for that material. $\endgroup$ – Joel Coehoorn Mar 11 '19 at 19:36
  • 1
    $\begingroup$ @Tinkerman255 Beware that it isn't inch ("), but the diameter is in millimeters [mm]. But you loose the unit once you divide the two. (One inch is 25.4 mm) $\endgroup$ – 0scar Mar 12 '19 at 6:08
0
$\begingroup$

The following saved me from under extrusion on Ender 3 Pro.

  1. Check the diameter of the material referenced and the nozzle parameter in your slicer (Cura, ...). Then re-slice.

  2. If not sufficient, it may be a printer parameter issue. The extruder parameter is missconfigured: the stepper to filameter distance ratio is not correct and as a result, it does not feed the requested length of filament. To fix the printer parameter, send the following gcode sequence (use a G-code console like "GCode Sender - Pronterface"). We will follow this procedure:

    • ask to feed 100 mm of filament
    • mesure the actual length feeded
    • read the parameter inside the printer
    • write correct value.

G-code:

M83 ; set to extruder relative mode
; Be ready to mesure how much filament will really be consumed
G1 E100 F100 ; request 100 mm of filament
; Let "L" be the length in mm you mesured
; Now read the extruder related value in the printer
M503 ; and let "V" be the last number at line "echo: M92"
; Then set the correct value 
M92 E{V*100/L}; Eg "M92 E222"
M500 ; write to memory
| improve this answer | |
$\endgroup$
  • $\begingroup$ It turned out to be the tensioning spring on the extruder drive that was the issue. It provided too much tension at first so loosening the screw that acts as the pivot for the extruder bearing arm solved that. However I found that filament then began to slip inside the extruder so adding a couple of spacers to the end of the spring fixed that. Now it's extruding great. $\endgroup$ – Tinkerman255 Feb 19 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.