3
$\begingroup$

I have problems with setting up Marlin for my new printer. Each time I rotate the dial, axis move to the same amount. It doesn't matter how much I moved it, to 1mm or to 20 mm (according to screen), axis move to the same really small step. It happens with all of axis. I tried to change step per unit to much higher value and it still does the same. Maybe you have some ideas guys? :)

$\endgroup$
  • $\begingroup$ Did you check the stepper current? Maybe the stepper tries to move, but doesn't succeed. $\endgroup$ – Lars Pötter Apr 9 '16 at 13:35
  • $\begingroup$ I figured out that problem was in my endstops. I solved it but still almost the same behavior. Already a bit better, but still not fine. I do not even know how to describe this behavior. Axis move but really weird, direction is correct but amount is wrong and quite random. I'll try to check current as a next step :) $\endgroup$ – Anton Osadchy Apr 10 '16 at 8:01
2
$\begingroup$

Update. Jumpers were inserted to 1/16, but stepper chip I have (9488) could not handle that many micro steps. I changed it to 1/8 and now it works good.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.