4
$\begingroup$

I'm assembling a 3D printer with the RAMPS 1.4 shield (board) and an Arduino Mega. I have assembled the structure and the electronics (set drivers, placed the jumpers, connected stepper motors, etc.) and have uploaded Marlin firmware (configuring: thermistor, etc.) on to the Arduino Mega.

At first I tested my printer without end stops and at that time it worked perfectly.

Today I added three end stops and tested again. First it worked fine but after couple of minutes Pronterface gave this error:

> Connecting...
Traceback (most recent call last):
  File "printrun\pronterface.pyc", line 1053, in connect
  File "printrun\pronsole.pyc", line 720, in connect_to_printer
  File "printrun\printcore.pyc", line 46, in inner
  File "printrun\printcore.pyc", line 197, in connect
  File "serial\serialwin32.pyc", line 31, in __init__
  File "serial\serialutil.pyc", line 261, in __init__
  File "serial\serialwin32.pyc", line 71, in open
  File "serial\serialwin32.pyc", line 186, in _reconfigurePort
**ValueError: Cannot configure port, some setting was wrong. Original message: [Error 31] A device attached to the system is not functioning.**

I tried removing end stops, re-wiring, removing all cables from the RAMPS shield except power cables. Still it gives that error. Although Pronterface connects to the Arduino board when the RAMPS shield isn't powered up. Also the Arduino's regulator is heating up.

Do I need to buy a new RAMPS shield?

$\endgroup$
  • $\begingroup$ It sounds like the USB to Serial port is either resetting or somehow loosing its configuration. Can you try changing the baud rate settings on the connection and trying to connect again. $\endgroup$ – Leland Wallace Apr 25 '19 at 1:07
  • $\begingroup$ I have tried with all baud rates. Still the error is there. I have tried to connect with the printer using different computer but it didn't work either. $\endgroup$ – Avishka Dambawinna Apr 25 '19 at 5:05
  • $\begingroup$ Today I tried to connect with a new RAMPS 1.4 shield it didn't work either but it over heated the voltage regulator and the main chip of my mega board. Now I'm getting time out error with the mega. $\endgroup$ – Avishka Dambawinna Apr 27 '19 at 14:50
1
$\begingroup$

Finally, I found the solution after frying up a Mega board. The problem is with the Mega board. Part of the board is not functioning properly or not connecting with the RAMPS 1.4 shield properly. So I tried with a new Arduino Mega board and it worked. Also removing the D1 diode is the solution for the voltage regulator overheating on Arduino mega board as mentioned in question "Arduino Mega voltage regulator overheats with RAMPS board".

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for coming back and sharing your solution! $\endgroup$ – 0scar May 9 '19 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.