2
$\begingroup$

In an attempt to upgrade my Ender 3 to TMC2208, I bought an MKS GENL 1.0 board from Banggood, but it doesn't get recognized from the Windows Device Manager at all: no COM port, no "Unknown Device", no beep when connected/disconnected via USB.

I have some Arduino and electronics experience and having an USBasp I've decided to give a go to reflashing the bootloader, with no joy. I tried flashing both the stk500boot_v2_mega2560.hex and the ATmegaBOOT.hex using avrdude like the following (copy pasted from Arduino IDE):

bin\avrdude -Cetc\avrdude.conf -v -patmega2560 -cusbasp -Pusb -Uflash:w:..\..\arduino\avr\bootloaders\atmega8\ATmegaBOOT.hex:i -Ulock:w:0x0F:m

Whatever I do the board seems dead: tried alternative cables (also double checked using a plain inkjet printer to confirm it wasn't that) and also alternative PCs (all running Windows)... I believe it might be possible for me to upload Marlin via ICSP, but without USB I'll have not much use for it anyway...

It might be worth noting the board uses a CH340 USB chip (drivers already installed), which seems to be getting only 2.6 V at VCC...

When connected via USB the red power on LED D7 turns on, but nothing else happens...

I'm about to throw the board into the bin and buy another one from Amazon, unless somebody has any suggestion that might revive it...

$\endgroup$
  • $\begingroup$ You might need a CH340 driver to be manually installed, although Windows normally installs that for you (whereas for OSX it is much more of a nightmare). See this for example, although, I presume (from your description) that Windows isn't even showing you an unknown device in Device Manager?. What is the error (if any) that you get when using avrdude? I've had issues like this before, and I've always been able to get them going again, usually with judicious use of the reset button and timing it just right. $\endgroup$ – Greenonline May 7 '19 at 20:19
  • $\begingroup$ CH340 driver is installed, but as windows in not recognizing ANY device I have no COM port to specify to avrdude. The usbasp bootloader programming via ICSP seems to complete nicely (both write and verify steps completed). I would generally agree with you with regards to resetting the board, but in this case it seems it's the CH340 being gone... $\endgroup$ – Roberto Lo Giacco May 7 '19 at 21:59
  • $\begingroup$ Hm, it doesn't sound good. This is a bit of a long shot, but the only thing that I can think of (at the moment) is to carefully monitor Device Manager whilst plugging in the board, and/or resetting the board. I had a mis-behaving Arduino-clone once that had a icon flash up only momentarily in the device manager (upon reset or plugging in) and if you weren't actually watching the device manager at the time you would never have known that it showed up briefly, and then disappeared. See here & its sequel. $\endgroup$ – Greenonline May 7 '19 at 22:09
  • $\begingroup$ Presumably you've seen this: Mks Gen L and nothing! (where the solution appears to be buy a new board!) and more promisingly Marlin compile and upload fails–MKS Gen L 1.0 (SOLVED) - among the many hints and tips, possibly there is a need for a CH341SER driver (rather than a CH340[G])? $\endgroup$ – Greenonline May 7 '19 at 22:27
  • $\begingroup$ @Greenonline the alt driver didn't help either, as I was expecting due the fact no device shows up to the device manager, not even momentarily. I also went a little to a lower level, trying to use zadiq to scan for any device having any USB signature, but the only USB devices recognized are those I already know (mouse, keyboard, USB hub, etc...) I would definitely rule out the driver problem at this stage... But thanks a lot for providing all that info and links $\endgroup$ – Roberto Lo Giacco May 8 '19 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.