I just bought and build my first 3d printer (HE3D K280 with Marlin) and I'm encountering some problems with Cura 4 and Repetier. When I load and slice a part, the printer does not extrude anything during printing. However, when I manually extrude like 100mm (G1 F100 E100) it does work. Now I'm suspecting the problem lies with the gcode file which is generated with Cura since it contains very small values for E:

 ;Layer height: 0.2
 ;Generated with Cura_SteamEngine 4.0.0
 M140 S60
 M190 S60
 M104 S200
 M109 S200
 M82 ;absolute extrusion mode
 G28 ;Home
 G1 Z15.0 F6000 ;Move the platform down 15mm
 ;Prime the extruder
 G92 E0
 G1 F200 E3
 G92 E0
 G92 E0
 G1 F1500 E-6.5

G0 F3600 X-7.753 Y4.378 Z0.3
G1 F1500 E0
G1 F1800 X-8.127 Y3.918 E0.01115
G1 X-8.35 Y3.57 E0.01893
G1 X-9.088 Y2.287 E0.04677
G1 X-9.348 Y1.754 E0.05792
G1 X-9.483 Y1.376 E0.06547
G1 X-11.413 Y-4.956 E0.18999
G1 X-11.547 Y-5.534 E0.20115
G1 X-11.602 Y-6.124 E0.2123

Does anyone know how to fix this?

  • $\begingroup$ How many heads is your printer capable of supporting concurrently? Have you tried entering a line with only T0 before your first G1 move? Do you know if you're slicing for linear or volumetric E values, and which your printer requires? $\endgroup$
    – Davo
    May 21, 2019 at 13:29
  • 1
    $\begingroup$ I does supprt 2 heads, however I'm using just 1. I just added T0 but unfortunately this did not work.. I'm slicing for linear but i tried with both and it did not extrude with either option $\endgroup$
    – Mikelo
    May 21, 2019 at 13:38
  • $\begingroup$ First thought volumetric flow, but on second thoughts: "What is the filament diameter in the slicer?" It looks as if the diameter is too large. $\endgroup$
    – 0scar
    May 21, 2019 at 13:53
  • $\begingroup$ Please edit this additional info into your question for future readers. $\endgroup$
    – Davo
    May 21, 2019 at 18:37

1 Answer 1


I think that you have the incorrect diameter specified (e.g. 2.85 mm instead of 1.75 mm) in your slicer; this also appears from a calculation, see below. Note that you can calculate from extruded volume entering the hotend, or deposited volume. For the first you could calculate the line width of the deposited line and verify that with the settings; from the second you can verify if the volume for the extruded filament equals filament volume based on extruded filament going into the hotend for an assumed line width. Do note that (certainly for first layers!) modifiers may be in place. This is merely to get a ballpark feeling for the chosen filament diameter.

If you look at the first move from:

G0 F3600 X-7.753 Y4.378 Z0.3


G1 F1800 X-8.127 Y3.918 E0.01115

You can calculate the travelled distance $ s = \sqrt{{\Delta X}^2+{\Delta Y}^2} = 0.59\ mm$. Also, from these moves you can see that $0.01115\ mm$ of filament enters the extruder $(E)$.

The deposited volume ($V_{extruded_filament}$) of the printed line equals the cross sectional area $\times$ length of the deposited filament path. Area could be defined as taken from e.g. the Slic3r reference manual to be:

Area of a deposited thermoplastic line

Basically (as we apply conservation of mass) the filament volume $(V_{filament})$ entering the hotend need to be the same as the extruded filament volume $(V_{extruded_filament})$ leaving the nozzle; so $ A_{filament}\times E = A_{extruded\ filament}\times s $.

This latter equation can be solved for $w$ by filling out the known parameters. From this calculation follows that for $1.75\ mm$ filament you get a calculated line width of about $0.22\ mm$, and respectively for $2.85\ mm$ filament you get $0.46\ mm$ line widths.

As the nozzle diameter has not been specified in the question, but most commonly used nozzle diameter often is $0.4\ mm$, and modifiers for the first layer are at play to print thicker lines; you most probably have the have the wrong filament diameter set if you have a $1.75\ mm$ extruder setup. Basically it under-extrudes.

  • $\begingroup$ I'd have thought that at least a little material would get pushed out in this case -- perhaps the retraction commands (for the wrong diameter again) keep material from ever getting to the nozzle output? $\endgroup$ May 21, 2019 at 15:59
  • 1
    $\begingroup$ @CarlWitthoft That would be in case the g-code is in relative coordinates, this is absolute. Not always after retraction, the nozzle is fully primed with the same length extrusion. $\endgroup$
    – 0scar
    May 21, 2019 at 16:27
  • $\begingroup$ This was indeed one of the problems! Another problem was that it didnt save the option that I wanted to slice volumetric (which was needed for my printer after all, manual of K280 sucks). Thanks for your help! :) $\endgroup$
    – Mikelo
    May 22, 2019 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .