Questions tagged [arduino-mega-2650]

The Arduino Mega 2650 is one of the most common microprocessor boards used to control 3D printers. If you think your Arduino is part of your issue, you can use this tag.

Filter by
Sorted by
Tagged with
1
vote
2answers
132 views

Is 12V and 15A enough to make work a Ramps 1.6 Plus and two stepper motors?

I want to make an order with this configuration Arduino MEGA 2650 R3 Ramps 1.6 Plus 2 TMC2130 2 Stepper motors 17hs3401 1 Fan But I am not sure what voltage and current would be enough to make it ...
1
vote
0answers
44 views

How do I access Configuration.h?

I am very new to 3D printing and I am trying to adjust my firmware. I use the Arduino IDE 1.8.12. I downloaded the firmware from GitHub that suits my printer, but every time that I try to open the <...
0
votes
0answers
25 views

Can't upload Marlin firmware to 3D printer because of “error: reinterpret_cast from integer to pointer”

When trying to upload Marlin firmware to my printer I get this error: error: reinterpret_cast from integer to pointer I'm using Tevo Tarantula with board MKS Gen ...
0
votes
1answer
36 views

Stepper motors not working when connected to RAMPS 1.4

Stepper motors are not working when connected to RAMPS board in the X,Y,Z pins. I used A4988 drivers and the Arduino board is an original version. I checked the input voltage to the RAMPS board, it's ...
2
votes
1answer
259 views

How to extend Marlin to support additional movement axis?

On a RAMPS 1.4 it is possible to mount 5 stepper motors: X,Y,Z steppers are used for ...
2
votes
1answer
371 views

Prusa i3, MK3: Firmware updated to 3.8.0. Display shows white blocks

About the printer: Prusa I3 MK3 [Sintron] Arduino Mega 2560 (just replaced) Replaced LCD / Smart controller FIRMWARE 3.8.0 Steps I have already tried: Replaced faulty Arduino Failed to flash ...
3
votes
0answers
62 views

Arduino Mega and RAMPS 1.4 not responding

I was working on upgrading my Anet A8 to a RAMPS 1.4 running on Marlin. I had everything ready to go and had plugged it in to see if it worked. It seemed to be working so I tried to home it and my y ...
2
votes
1answer
263 views

Marlin on Arduino Mega 2650 and RAMPS 1.4

I have been messing around trying to flash marlin 1.1 onto my Arduino Mega 2650 and RAMPS 1.4. I have Managed to get it to upload fine however it will not upload with the LCD I want. I am trying to ...
4
votes
1answer
226 views

Using extruder motor as 4th axis

I am currently working with a hobbyist robotic arm (uArm Swift Pro) which runs a modified version of Marlin 3D printing firmware. The arm can be used as a 3D printer as well thus it has an extruder ...
2
votes
0answers
562 views

MKS GEN L looks dead

In an attempt to upgrade my Ender 3 to TMC2208, I bought an MKS GENL 1.0 board from Banggood, but it doesn't get recognized from the Windows Device Manager at all: ...
5
votes
1answer
1k views

Configuring of MKS_GEN_L V1.0

I've bought a new "MKS GEN_L V1.0" and I'm trying to configure it with Marlin 1.1.X. I changed motherboard in configuration.h from previous: ...
4
votes
1answer
2k views

How to test Arduino Mega, RAMPS 1.4 and Full Graphic Smart Controller LCD?

Unfortunately, my extruder 8825 driver ended up fried. I guess this might have damaged the Arduino Mega and RAMPS Board. I tested the Arduino Mega and I'm pretty sure that it is fried too, so I ...
1
vote
1answer
209 views

Free UARTs TX and RX pins on CR-10S motherboard

I have a WiFi module that only needs two wires connection to work. These are RX and TX pins connected to Arduino or the CR-10S printer board but I don't know if there is any physical or software UARTs ...
4
votes
2answers
2k views

Stepper motors are not working when connected with RAMPS 1.4

ISSUE: Stepper motors are not working when connected with RAMPS 1.4. OBSERVATION: The LED lights(LED 2,3,4) in the RAMPS 1.4 is not powering up. PRACTICES: I use Arduino Mega 2560 and installed ...
4
votes
1answer
138 views

MKS board losing power after endstop installation

I just bought an MKS gen v1.3, and everything on it works fine except for when I plug in the endstops. My X endstop works perfectly in every endstop outlet, but when I plug in my Z and Y endstops, the ...
6
votes
1answer
394 views

Thermister stops reading temp after a few seconds. (Marlin 1.1.8, Tronxy X5s stock Melzi board)

I think it's best that I explain what my issue is before I explain how I arrived here. I have a Tronxy x5s with a stock board that I am repairing for the sake of repairing, even though I know I should ...
5
votes
1answer
393 views

Linking an Arduino Mega with RAMPS and an Arduino Uno with CNC Shield to control more stepper motors using Marlin firmware

I've been looking for this for a while, and it looks like no one has tried it before. Does anyone know if there is a way to link an Arduino Mega with RAMPS as master, with an Arduino Uno with a CNC ...
4
votes
2answers
525 views

Ramps 1.4 with a power brick

I'm currently designing a RepRap 3D printer that will not have a heated bed. I have heard that it is possible to use a power brick with commercial printers lacking heatbeds. Is this possible with a ...
3
votes
1answer
4k views

How do I use MEGA pin number designations rather than RAMPS pin numbers in marlin

I am designing my own shield for the MEGA2650 that I will use to control my printer. When defining pins in the marlin firmware, the pin numbers are the pin numbers of the RAMPS shield and not the ...
4
votes
1answer
235 views

Printrun doesn't connect when 12 V is on

I'm able to connect to Arduino+RAMPS through USB. I can even check end stops with M119. However, if I plug it to the power supply, my MacBook goes crazy and restart ...
4
votes
2answers
1k views

Z axis at print is lower than when I home

I replaced the controller board in my Monoprice Select Mini with an Arduino/Ramps setup and compiled an uploaded Marlin 1.1.0-RC8 to run it. I've got most everything calibrated and working with one ...
0
votes
2answers
493 views

Arduino 3D printer sketch [closed]

I'm building an automatic warehouse system using three NEMA 17 stepper motor. My problem is to move the motors with precision, since I do not have any kind of encoder on the motor and so I cannot ...
4
votes
1answer
772 views

Has anyone used a Shield Buddy (en lieu of a Arduino Mega2560) as the RAMPS 1.4 host board?

I have read a few times1 that the Arduino Mega can struggle to perform the tasks required for 3D printer control, as the AVR chip is working at its limits, and this is why some manufacturers have ...
4
votes
4answers
10k views

How to directly send G-code to printer from a Linux terminal?

Should it be possible to directly send G-code to the printer serial connection using pipes under Linux? Example: echo M106 > /dev/ttyUSB0 My controller runs ...
5
votes
2answers
848 views

Wanhao i3 PLUS restarts when connecting USB

I just received my Wanhao Duplicator i3 PLUS. Everything prints and functions fine via SD card and the display but when connecting to my Mac computer the printer seems to restart. Baud Rate: 115200 ...
5
votes
2answers
806 views

Uploading Repetier firmware to Arduino?

I have a prusa i3 and have been trying to calibrate it. I have been trying to upload the new steps per mm and I get to done uploading. However when I go into Repetier host and type M503 to get the ...
3
votes
2answers
7k views

How can I program a 3D printer to move using Arduino?

I search about that topic, but all what I found, was the mechanical part of the 3d printer. But I didn't find, how to program it using arduino. I want to make a cartesian 3d printer. I don't have a ...
2
votes
1answer
609 views

What is the MightyBoard 1280 IO used for?

While I've worked on fixing my voltage regulator on my MightyBoard, I've noticed an extra set of pins available labeled Atmega 1280 IO. I've tried finding documentation on what these pin can be used ...
7
votes
1answer
1k views

Using an Arduino Mega with burnt voltage regulator

Due to a not-given compatibility with Makerbot mechanical endstop wiring (and carelessness on my side) I ended up burning the voltage regulator on my Arduino Mega 2560. Now, powering the Arduino ...
5
votes
1answer
847 views

Why does my MKS Base not recognize my thermistors?

I recently upgraded my Geeetech Acrylic Prusa i3 with a MKS Base V1.4 and it would not recognize the thermistors (100K {type 1}) even though they worked fine with the Arduino Mega 2560 with the RAMPS ...
6
votes
1answer
743 views

Marlin menu navigation slow while printing

My Kossel Mini printer (delta) has RAMPS1.4/Arduino Mega electronics configured to use a standard 20x4 LCD display with Marlin during printing. Often, navigating the menus during print can be ...
9
votes
3answers
3k views

Tips for not burning out my Arduino Mega or catching something on fire when wiring a Prusa i3?

I'm reading about wiring up the electronic components to my Prusa i3 using an Arduino Mega 2650 and Ramps 1.4. I have step sticks, a heated bed, and a Switching Power Supply 12v Dc 30a 360w (more ...