Questions tagged [marlin]

Questions about the 3D printer firmware Marlin.

Filter by
Sorted by
Tagged with
2
votes
1answer
24 views

Print not sticking to bed

Today I ran into an issue with the filament not sticking to the build plate. However, the strange part is, that this only happens with one filament color (both PLA, khaki, black works just fine) and ...
1
vote
1answer
12 views

3 Extruders on SKR V1.1, how set up 2 in 1 out (Y piece), and 1 single extruder in latest Marlin?

On Anet A8 with SKR V1.1 32 bit board my intention is to use 3 extruders on my Anet A8, 1+2 via Y-piece on single nozzle, 3rd Extruder with 2nd nozzle. Need another stepper to connect to SKR V1.1 (10 ...
0
votes
0answers
12 views

Anet A8 BLTouch bed leveling starts outside of bed

I just upgraded Anet A8 to Marlin 2.0.x with BLTouch, but my issue is when I press bed level the center is not correct, and when it goes to the first point it is outside of the bed. My BLTouch is back ...
0
votes
0answers
30 views

G28 is not homing to center of bed

I've got a heavily modified CR-10s Pro, and I'm compiling my firmware. I have my own x-carriage with the probe changed to the right of the nozzle. The bed size is 300x300. Oddly, when I do a G28 the ...
1
vote
1answer
31 views

First move after homing way too fast

There are a few hits on my issue title but could not find an actual answer/advice. I burned my Ender 3 Pro Creality motherboard and replaced it with an SKR 1.4 + TMC 2209 + BLTouch. Everything is ...
3
votes
1answer
31 views

Ender 3 Pro, Motherboard v4.2.7, Marlin 2.0.1 Firmware reset

Upgrading motherboard to v4.2.7 How do I reset the firmware after making wrong mods?
0
votes
1answer
39 views

Printer shaking - Marlin 2.0

I just replaced the board on my Creality CR-10 with a 32-bit SKR Mini E3 V2.0 control board that runs Marlin 2.0. With the new control board, the printer's Y-Axis moves vibrate so much that it blurs ...
2
votes
2answers
55 views

Prints are mirrored in X-axis and inverted in Y-axis direction

My custom 3D printer prints everything inverted. I guess this is a homing problem as the motor moves in correct direction. In Pronterface, if I press -Y — bed moves forward (towards the Y endstop) if ...
4
votes
1answer
54 views

Marlin is restarting when pins 5 Vcc are enabled and has a servo motor connected (RAMPS 1.4)

My printer uses an ATMega 2560 with a RAMPS 1.4 shield, A4988 stepper drivers and a 2004 controller LCD interface. The PSU is 360 W (12 V, 30 A). I bought a BLTouch for my printer, but when installing,...
0
votes
0answers
18 views

Sending multiple commands to printer without overloading its command buffer [duplicate]

I am writing a python code for a 3D printer (Marlin). I'm trying to execute a movement that might be composed of multiple commands (G0). Unfortunately, sending all ...
1
vote
0answers
19 views

How to enable Z-offset on MKS TFT28 V4.0

I am trying to enable Z-offset on MKS MKS TFT28 V4.0 touch screen but I couldn't for some reason. This is the code that I have uploaded to the Screen firmware in which you can see that I have enabled ...
3
votes
1answer
317 views

Stepper Motors getting extremely hot

I installed MKS Gen L V2.1 with TMC 2209 drivers to my Creality Ender-3 printer and updated the software to marlin 2, the stepper motors are getting extremely hot. What should i due to resolve this ...
2
votes
0answers
42 views

BLTouch not covering the whole bed area

My problem is that the BLtouch doesn't probe the whole bed, in which the probe starts from the left edge and stops at the middle of the bed. I'm using Marlin 2 software and this the code in the ...
2
votes
1answer
49 views

G-code wait for extrude command to finish

I have following G-code to prime the nozzle before start of the print. ...
1
vote
0answers
52 views

What could cause these slight waves on the print?

The model of the test part is perfectly smooth and exported/sliced in very high resolution, yet there are slight waves on both axis. These waves are not visible in simulation. Converting to arcs via ...
5
votes
1answer
848 views

Ender 3 V2 blank screen and LCD continuous beeping with clicks

So I have been having an ongoing problem with my printer that I just can't solve. I don't usually ask the questions on stack exchanges until my problem gets unsolvable. Unfortunately like this one ...
1
vote
0answers
125 views

BLTouch does not compensate for bed level correctly

Printer: Anycubic Mega S. Mods: BLTouch, Dual material with G-code-powered switch. Firmware: Marlin 2.0 A couple of weeks ago I had a print failure when printing PETG. Now whenever I use auto bed ...
0
votes
0answers
32 views

Automatic leveling of the bed does not work

I am trying to run the G29 G-code for my 3D printer to automatically level the bed of the printer. Every time I try run the G-code my printer just beeps and nothing ...
0
votes
0answers
62 views

Marlin v. Repetier G-code flavor

My TronXY X1 runs on Repetier firmware. My Ender 3 runs on Marlin firmware. I found that apparently code in Marlin style does not always create good prints on a Repetier machine, under extruding in ...
1
vote
2answers
42 views

How to setup Marlin to use a moving bed (up-down)?

I am building a 3D printer from scratch, the bed will only move on Z and the head will stay at the top of the printer and move X and Y. How do I modify the Marlin firmware to have the bed lower as it ...
1
vote
2answers
26 views

Printer thermistors read completely wrong after changing firmware

I recently installed Marlin 1.1.9.1 onto my Creality CR-10S. After doing so, the temperatures for both the bed and hotend now read -14 °C. I have changed the setting in the Marlin ...
2
votes
0answers
82 views

Should center point of G29 matrix always be zero?

Questions: Should repeated applications of G29 (auto-level) result in the same matrix as long as nothing is loose or has otherwise mechanically changed? Should ...
1
vote
1answer
29 views

How to make it so that multiple motors respond to

I want to make it so that the E1 and E0 do exactly the same as the Y motor and I was wondering if anyone here knew how to do that? I basically just want to make it so that when the Y motor is ...
1
vote
0answers
29 views

How to code for the BTT expansion board? [closed]

Does anyone know how to adjust the firmware for the BTT expansion module? I am going to be using this(https://github.com/bigtreetech/BTT-Expansion-module/tree/master/BTT%20EXP-MOT) to add three ...
0
votes
0answers
27 views

PID Autotune not working and M92 calibration not saving?

I have a Witbox 2 running Marlin that I got second hand and it seems like nothing is able to be calibrated on it. I have tried many times to get the nozzle calibration to save but it never seems to ...
1
vote
0answers
56 views

BLTouch Creality Firmware works, Marlin doesn't

I've had the BLTouch working fine using this kit and following the instructions it shipped with. I wanted to increase the number of probe points so I've attempting flashing with Marlin to achieve this....
0
votes
0answers
11 views

I am installing a BTT 24 v1.1 and it appears to be functioning in the 12864 mode with the exception of the top two lines which are gibberish

I am installing a TFT24 v1.1 and it appears to be functioning in the 12864 modes with the exception of the top two lines which are gibberish. I have attempted to block both the boot and the custom ...
1
vote
2answers
48 views

Can't get Y-Axis to move with Marlin firmware

Just as the title says. I feel like I have tried everything. I am compiling the firmware for Marlin on a Megatronics board from RepRap. That shouldn't be relevant, because I have validated that it is ...
4
votes
1answer
181 views

Why are fast printed lines thinner?

I have run the K-factor Calibration Pattern generator to tune LIN_ADVANCE and found that when K=0, the whole middle part of the ...
0
votes
0answers
50 views

How to specify servo pin for BLTouch sensor in Marlin

I have been through a bunch of different examples/tutorials/other threads. But I can't figure out how to let the firmware know what servo pin is used for the BLTouch sensor in the latest Marlin 2.0.c ...
2
votes
1answer
67 views

Marlin: Why is the extruder stepper jerking?

Environment: Printer: Anycubic Chiron, Firmware: Marlin 2.0.7.2, Settings: FWRETRACT is not enabled, Slicer: Cura 4.8.0. When I print using the code below (it is longer, but I do not know where to ...
1
vote
1answer
112 views

Ender 3 + SKR 1.4 + Marlin 2.0.x bugfix - what bed size/min/max positions should I use?

On my Ender 3, it seems that the Y-axis can only move forward 220 mm after which the carriage will hit the tensioner. This seems repeatable so I don't think it's a hardware issue (unless it's expected ...
1
vote
1answer
48 views

How to programmatically resume a paused print in Marlin

A print that is paused with an M0 can be unpaused with M108. That works with my Chiron running Marlin 2.0.7.2. However, it also ...
2
votes
0answers
66 views

Marlin RAMPS 1.4 reboot problem while printing via SD card

I have a custom 3D printer with RAMPS 1.4 and Arduino Mega 2560 (clone). I installed Marlin 2.0.7.2 firmware and I tested all the motion and heating parts individually and all of them work fine. Also, ...
1
vote
1answer
38 views

Z-step pulses too short (Marlin 2.0.x)

I was replacing a stepper driver on my Melzi 2.0 board with a A4988 Pololu module and for some reason, it won't cooperate with Marlin. For reference, I'm using a Melzi 2.0 TRONXY with a ZONESTAR-style ...
0
votes
0answers
22 views

3D printer Endstop doesn't trigger in Pronterface when depressed

I am using Makerbot endstops connected to a RAMPS 1.4/Arduino Mega 2560 setup. I am using Marlin firmware and Pronterface. When I send the M119 command, all six (I'...
1
vote
1answer
139 views

Marlin firmware: move without auto bed leveling

I am working on a filament unload script. My current problem is that the script always does an auto bed leveling. I have two scripts to test this issue: ...
2
votes
1answer
214 views

Marlin firmware: unload filament with G-code

I have upgraded my ER-20 with a Bondtech dual gear feeder. It is not or hardly possible to load/unload filament manually with this feeder, so some .gcode is needed to do it. I wanted to implement ...
1
vote
1answer
65 views

Z-Axis on i3 clone won't move at all, Melzi A4982 driver problem

I'm setting up a replacement Melzi 2.0 board from TRONXY for my i3 clone (a Monoprice Maker Select v2 for those curious), which according to the RepRap wiki has A4982 drivers for all the steppers. I'm ...
1
vote
0answers
51 views

Anycubic Kossel Delta switch from Trigorilla to MKS Gen L 1.0

I have an Anycubic Kossel Delta 3D Printer. The original Trigorilla motherboard died and I decided to buy one but I only found a Makerboard MKS Gen L 1.0 which is said to be compatible with Trigorilla....
2
votes
1answer
64 views

Extruder motor does spin - but not while printing

I hope someone can poke me in the right direction, I´ve been failing to find a way around this problem and trying for about a week. My setup is pretty custom, I am using a BTT SKR 1.4 Turbo with ...
1
vote
2answers
56 views

What modifications do I need to make to Marlin if I completely replace the heated bed assembly?

I have a 3D printer built from generic, scrap parts. It's controlled by a 2+ years old MKS GEN L board running Marlin version ...
3
votes
1answer
82 views

Probe instead of nozzle centres on the bed

Problem is that the probe is in the center of bed instead of the nozzle. How fix it on my Tronxy X5SA? Those are my current settings and the nozzle is shifted from the centre (X: 35 mm, Y: 3 mm): <...
2
votes
2answers
148 views

Issue with Z homing on Ender 3 Pro with Marlin

I've just changed the motherboard on my Ender 3 Pro with a MKS GEN_L v1.0 and flashed the latest Marlin version on it. I've calibrated my bed manually using the default XY and Z auto home commands on ...
1
vote
1answer
165 views

Ender 3 Marlin - Incorrect temperature

I've updated to Marlin 2.0.7 when I set up a BLTouch and now it seems the temperature does not match the display. Before the update, I was printing with PLA filament at 205 °C and bed at 60 °C without ...
2
votes
1answer
203 views

Understanding of the auto bed leveling process (BLTouch)

I just installed my BLTouch clone (Marlin 1.8) on my Anycubic i3 Mega Ultrabase and finding confusing information about the Z_PROBE_OFFSET_FROM_EXTRUDER or the M851 ...
3
votes
2answers
102 views

Z axis no longer working on a working printer

I was printing an object and it started to drag so I stopped it. Went to move the Z-axis up so I could clear the bed and Z-axis would not budge. I switched the printer off and manually turned the ...
1
vote
2answers
266 views

How do I set my Z offset?

After watching every possible YouTube video on the subject and reading any source available, and although I'm a PhD and quite computer savvy, I still can't make my Anet A6 (no probe) behave in terms ...
0
votes
0answers
18 views

Marlin PID temperature control look werid

As you see in the picture, the heater turn on with 100% power (without PID) until it reach some gap say 5 degree C from setpoint then the PID start. I not sure why the heater power decrese to zero ...
0
votes
0answers
35 views

Hotend functioning inconsistently. PID completed normally, heating to quickly or not at all on print start up

I have a Xvico X1 printer which I had previously installed an SKR 1.3 on running Marlin, which was functioning normally. For Christmas I got a BLTouch, a heated bed and a Raspberry Pi for it, so I ...

1
2 3 4 5
9