Questions tagged [marlin]

Questions about the 3D printer firmware Marlin.

Filter by
Sorted by
Tagged with
1
vote
1answer
29 views

Marlin firmware 2.0.9.1 for X5SA example : MM_PER_ARC_SEGMENT Compilation Error

I have a Tronxy X5SA printer upon which I want to install the latest Marlin firmware v2.0.9.1. I take the configuration example on GitHub for the X5SA printer and modify the lines in ...
1
vote
1answer
3k views

After installing BLTouch and Marlin, my nozzle is too high when trying to print

So I have an AnyCubic i3 Mega to which I added a BLTouch v3.1 and Marlin (1.1.9 due to older, Atmega 8-bit CPU) using instructions and such from this link. Finally, I've got everything moving in the ...
0
votes
2answers
2k views

Z offset in Marlin is not working recently

My printer is ignoring the "Z offset" setting in Cura and the "Bed Z" stored in the printer LCD settings? It has been working before but after a firmware update of my printer, it ...
0
votes
0answers
44 views

what type of safety glasses/ goggles should be worn when using ACETONE? [closed]

Work in a dental lab, looking for a goggle or safety glasses that wont get pitted by acetone?
1
vote
0answers
39 views

Tronxy X5SA not working properly after Marlin firmware installation

Yesterday I just installed Marlin firmware, 2.0.x bugfix version on my Tronxy X5SA (v6). I did it in the way explained on GitHub, with Visual Studio Code, Platform IO, Marlin auto build. I applied the ...
2
votes
1answer
53 views

How to make Ender 5 use BLTouch probe for Z homing?

Backstory I set up the BLTouch module as explained in the guide that came with it - that included unplugging the Z axis switch, and replacing it with a pair of wires from the BLTouch module. I managed ...
1
vote
1answer
69 views

Printer halted! Psu dead?

My Anet A8 Plus worked normally, but after the weekend and changing for new bearings on the rods, it is not working anymore at all. I experience random reboots, the nozzle can only heat to about 10 °C ...
1
vote
0answers
25 views

M503 command is reporting "Maximum feedrates" with duplicate and empty values: M203 X200.00 Y200.00 Z5.00 E Y1000.00 Z100.00 E5000.00

I'm pretty stumped on this one. Investigating an issue I was having with an OctoPrint plugin, I've come to realize my M503 command is reporting duplicate and empty ...
3
votes
1answer
54 views

How to add custom physical buttons to a 3D printer in Marlin software

I have a 3D printer with MKS Robin mainboard + TMC2209. How do I add a piece of code to Marlin, for example, to make a physical button to start preheating, etc. I would like to use the existing ...
4
votes
2answers
2k views

Can G-code scripts be run automatically on inserting an SD card when using Marlin Firmware?

When running Marlin Firmware, is it possible to run G-code scripts/series of commands automatically when you insert the SD card? I'm running Marlin on a 3D printer board using an ATmega 2560 based ...
0
votes
1answer
901 views

UBL Marlin settings to cover whole bed

This question is related to: How to set Z-probe boundary limits in firmware when using automatic bed leveling? I am trying to figure out how to set UBL In Marlin to cover as much bed as possible. So ...
0
votes
1answer
38 views

Ender 5 SKR Mini E3 -- After Heating the Hot End Assembly Runs into the side of the printer

So I got the SKR mini E3 for my Ender 5 after hearing all the positive reviews. When it arrives I plug everything in, make sure it's secure and test the axis... they all worked correctly. I then ...
4
votes
1answer
64 views

Creality 4.2.7 problem connecting to Windows

I've had an Ender 5 for quite a while and it has worked phenomenally, but recently I had encountered a MIN_TEMP error so I ordered a new hotend and Creality silent board. Because this is an Ender 5, I ...
2
votes
1answer
799 views

Why is BLTouch Still Probing Off the Bed Even When `NOZZLE_TO_PROBE_OFFSET` is Set?

So I am almost finished upgrading my CR10s with Hemera and BLTouch hardware, however I can't get past this one problem. In the picture, you can see that the probe is to the left of the nozzle, and ...
4
votes
0answers
56 views

CR-10 MAX - Marlin Firmware settings help

I’m trying to build firmware for the CR-10 MAX. The git has no config example for this machine. And this is the first time for me to look into the settings. I’m ...
2
votes
1answer
47 views

TronXY X5S system (Marlin) - Very Slow menus

This is my board MKS Melzi v2.0 cloned I replaced the MCU (the actual IC) with new ATmega1284P 16 MHz, because the old MCU was damaged - the reason was that the fan got dusty and the power line ...
2
votes
1answer
40 views

X-axis homing failed with odd results on Tevo Tarantula

I recently finished building my Tevo Tarantula but now I have an issue with homing the X-axis. I have uploaded MarlinTarantula EasyConfig 2.0.x firmware with Arduino Version 1.8.15 on to the Tevo ...
2
votes
3answers
59 views

Extrusion issues on medium speeds (while accelerating?)

I've recently changed my Ender3's hotend to E3D v6 clone with Titan direct extruder, so I can print faster than on stock. But when I increased the speed up to 70 mm/s for walls and 80 mm/s for infill (...
3
votes
1answer
43 views

CR-10 randomly loses connection to computer when printing over USB

I have a Creality CR-10 which is running Marlin because I have a BLTouch installed. All was working fine until it suddenly had an issue where it would lose connection to the computer mid-print when ...
1
vote
2answers
100 views

Ender 5 Plus manual screen temperature adjustment

I want to get my Ender 5 plus to print at 300 °C. As such, I've edited the firmware and increased the HEATER_0_MAXTEMP to 315 °C. In my slicer, I can slice and ...
9
votes
3answers
101k views

Recalibrating Home-position

I got myself the Ender 3. The Home position is about 1 mm left and 2 mm in front of the front left corner. Now, the hotend center axis is 11 mm from the carrier plate with the "Mk 10" cooler ...
1
vote
1answer
542 views

Ender 3 Marlin - Incorrect temperature

I've updated to Marlin 2.0.7 when I set up a BLTouch (I've edited configuration.h based on my board model; MKS Robin E3) and now it seems the temperature does not ...
4
votes
1answer
137 views

Creality Ender 3 Pro - Z travel issue with TH3D firmware

TLDR - I’ve just driven myself insane trying to fix what I thought was a physical problem with my Z-axis, but it seems to have been solved by switching from the TH3D firmware to the Creality firmware. ...
2
votes
1answer
205 views

Does updating the firmware on an Ender 3 V2 erase its previous settings?

A few months ago, I flashed my Ender 3 V2 with JyersUI fork of the Marlin firmware and I like the options and settings that are available with this firmware. The author has put out another update (v1....
0
votes
2answers
79 views

Hotend temperature goes to infinity after few layers

I have a "classic" home built 3D printer, Arduino Mega, RAMPS 1.4 with Marlin 2.0. It worked, was put in storage, and now I am trying to get it running again. During all of the testing ...
2
votes
0answers
59 views

Bricked Mks Rumba+ Board after Power Supply Trouble

This is my first time posting on this forum, so bear with me: This is my first attempt at a RepRap project, and my go-to board has been the RepRapDiscount MKS Rumba+ since I wanted to have ...
1
vote
1answer
219 views

Marlin firmware: move without auto bed leveling

I am working on a filament unload script. My current problem is that the script always does an auto bed leveling. I have two scripts to test this issue: ...
2
votes
1answer
212 views

Extusion rate limiting and firmware retract

One frustration I have with Cura is that it has no way to set print speed in terms of a volumetric extrusion rate, when extrusion rate is the main physical limiting factor for how fast you can print. ...
2
votes
1answer
149 views

How to define bed dimensions in Marlin for custom carriage / hot end?

How would I begin measuring my hotend / carriage dimensions in Marlin to prevent my hotend from slamming into the frame? I see in Marlin the 'define bed size' parameters ...
1
vote
1answer
1k views

Bed probing feed rates

I was watching a friend's Prusa run the bed-probe routine and I realized how pathetically slow mine is and takes forever. I want to speed it up. What parameters in Marlin's ...
9
votes
3answers
11k views

Endstops will not trigger using Marlin Firmware

I have an old Solidoodle 2 that I bought broken from a garage sale that I am converting to use RAMPS 1.4 with Marlin Firmware. All the motors work correctly, I am just having issues getting the ...
2
votes
1answer
17 views

Separate Z-stepper E-steps

I have three stepper motors each with its own stepper driver. Two of those motors have the same lead screw, while the third has a ball screw. I need to be able to set the E-steps for the ball screw ...
8
votes
6answers
21k views

BLTouch Probing Fails Intermittently

I just installed my (v3) BLTouch with a vanilla version of Marlin (1.1.9) on my Ender 3 and everything seems to work fine (including auto home) except the probing. It repeatedly does the first three ...
4
votes
1answer
3k views

CR-10S / Ender5+ LCD Touchscreen Firmware Editing

How would I go about editing the LCD menus for the touchscreen? Oddly the Ender 5+ is supposed to be an upgrade but the Ender 5 (regular) has so much more stuff you can control from the LCD screen. ...
2
votes
0answers
35 views

Bioprinter does not extrude Anet A8 Marlin

I have a modified Anet A8 that is supposed to print hydrogels (paper : Ultra-Low-Cost 3D Bioprinting, Kahl M et al. 2019). For this to work, we do not need any temperature-related settings, however, I ...
0
votes
1answer
90 views

Ender 5 with 8-bit Creality 1.1.4 board- Issue with speed of extruder motor spinning too slow

The issue I'm having is that the extruder motor is not spinning fast enough so the filament doesn't come out as fast as I would like it to. In terms of the specs, the printer is an Ender 5 that has ...
0
votes
1answer
57 views

Stepper motor moving only to one side after reset

I come through this post, rescue a problem with my printer. It uses Arduino 2560 Mega, RAMPS 1.4, and Marlin 1.1.9, which had configured it left it working as follows: on the RAMPS the Y-axis is ...
1
vote
1answer
249 views

Ridges and stepping in my prints

I'm having a problem where every few layers seems to be offset slightly, creating a stepping effect. The images below should be smooth along the sides, but having this ridge type effect. My question ...
0
votes
0answers
48 views

Using external stepper driver

I need to add two external stepper drivers to my MKS Gen L board. I am using E1 as an extra Y-axis and that is working great. I have three Z motors and I want to ...
1
vote
1answer
23 views

3 Extruders on SKR V1.1, how set up 2 in 1 out (Y piece), and 1 single extruder in latest Marlin?

On Anet A8 with SKR V1.1 32 bit board my intention is to use 3 extruders on my Anet A8, 1+2 via Y-piece on single nozzle, 3rd Extruder with 2nd nozzle. Need another stepper to connect to SKR V1.1 (10 ...
0
votes
0answers
19 views

Help adding additional stepper drivers to Marlin

I am building a large printer that needs 3 independent Z-stepper motors that will home with a BLTouch and 2 Y-stepper motors with an endstop for each side. I can use the ...
1
vote
0answers
23 views

Odd behaviour of steady feedrate increase

For some weeks I noticed really odd behaviour on my OctoPi controlled Anet A8. I'm using an MKS Gen L board with TMC2208 on this and constellation worked for a year now. When starting a print, I ...
0
votes
0answers
16 views

BLTouch goes behind print bed

I want to install Marlin 2.0 on my CR20 Pro but when I try to level the bed it goes behind the bed (in my direction on the Y axis). Here is my bed config: ...
3
votes
0answers
150 views

Retraction fine but recovery occasionally just doesn't happen

I'm having issues with retraction. My printer prints very well normally, but has an intermittent problem with retraction: the retraction itself always happens, but sometimes the subsequent recovery ...
5
votes
3answers
8k views

How to change E0 to E1 on Marlin 1.1?

I have the same problem as this person but I don't have those lines in my RAMPS.h file as seen here. I've recently burnt my potentiometer on E0 so the motor isn't ...
7
votes
1answer
27k views

How to increase the amount of probing points for a BLTouch sensor in Marlin firmware?

I have a new BLTouch that is setup (using Marlin 1.8.7) but I want to increase the probing grid from a 3x3 to something like a 5x5. I am using bilinear leveling with a 3x3 grid. How would I go about ...
2
votes
1answer
85 views

How can I print in multicolor with Ender 6?

I'd like to make multicolor printing on Ender 6, but it seems that the filament change (ADVANCED_PAUSE_FEATURE) doesn't work (it works on my Ender 3). Can you help ...
1
vote
0answers
28 views

Receive M114 command while printing using Printrun

I'm working on a project for which I use the Printrun package to serial communicate my G-code to my 3D printer (Creality Ender 3, Marlin firmware). The idea is that I have an external button connected ...
2
votes
3answers
85 views

Print not sticking to bed

Today I ran into an issue with the filament not sticking to the build plate. However, the strange part is, that this only happens with one filament color (both PLA, khaki, black works just fine) and ...
3
votes
1answer
112 views

Height of the prints are always larger

This problem is driving me crazy, no, seriously speaking. I bought this printer this week and started to calibrate for accurate dimensions. I printed the one-and-only calibration cube (20x20x20 also a ...

1
2 3 4 5
9