Questions tagged [marlin]

Questions about the 3D printer firmware Marlin.

94 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
0
votes
0answers
37 views

G28 is not homing to center of bed

I've got a heavily modified CR-10s Pro, and I'm compiling my firmware. I have my own x-carriage with the probe changed to the right of the nozzle. The bed size is 300x300. Oddly, when I do a G28 the ...
0
votes
0answers
37 views

Automatic leveling of the bed does not work

I am trying to run the G29 G-code for my 3D printer to automatically level the bed of the printer. Every time I try run the G-code my printer just beeps and nothing ...
0
votes
0answers
105 views

Marlin v. Repetier G-code flavor

My TronXY X1 runs on Repetier firmware. My Ender 3 runs on Marlin firmware. I found that apparently code in Marlin style does not always create good prints on a Repetier machine, under extruding in ...
0
votes
0answers
39 views

PID Autotune not working and M92 calibration not saving?

I have a Witbox 2 running Marlin that I got second hand and it seems like nothing is able to be calibrated on it. I have tried many times to get the nozzle calibration to save but it never seems to ...
0
votes
0answers
12 views

I am installing a BTT 24 v1.1 and it appears to be functioning in the 12864 mode with the exception of the top two lines which are gibberish

I am installing a TFT24 v1.1 and it appears to be functioning in the 12864 modes with the exception of the top two lines which are gibberish. I have attempted to block both the boot and the custom ...
0
votes
0answers
87 views

How to specify servo pin for BLTouch sensor in Marlin

I have been through a bunch of different examples/tutorials/other threads. But I can't figure out how to let the firmware know what servo pin is used for the BLTouch sensor in the latest Marlin 2.0.c ...
0
votes
0answers
31 views

3D printer Endstop doesn't trigger in Pronterface when depressed

I am using Makerbot endstops connected to a RAMPS 1.4/Arduino Mega 2560 setup. I am using Marlin firmware and Pronterface. When I send the M119 command, all six (I'...
0
votes
0answers
18 views

Marlin PID temperature control look werid

As you see in the picture, the heater turn on with 100% power (without PID) until it reach some gap say 5 degree C from setpoint then the PID start. I not sure why the heater power decrese to zero ...
0
votes
0answers
37 views

Hotend functioning inconsistently. PID completed normally, heating to quickly or not at all on print start up

I have a Xvico X1 printer which I had previously installed an SKR 1.3 on running Marlin, which was functioning normally. For Christmas I got a BLTouch, a heated bed and a Raspberry Pi for it, so I ...
0
votes
0answers
62 views

How can I improve dimensional accuracy of a delta printer?

I have a delta printer that I am trying to fine tune. I have printed a 20mm calibration cube and I get the following measurements: X: 20.5 Y: 20.3 Z: 20.0 How can ...
0
votes
0answers
56 views

How to replace Trigorilla mainboard with MKS Gen L 1.0

I have the following printer: Anycubic Kossel. This has Trigorilla mainboard. My mainboard is dead and it's very expensive or almost impossible to replace it with another Trigorilla mainboard. There ...
0
votes
1answer
2k views

After installing BLTouch and Marlin, my nozzle is too high when trying to print

So I have an AnyCubic i3 Mega which I added BLTouch v3.1 and Marlin (1.1.9 due to older, Atmega 8-bit CPU) using instructions and such from https://github.com/MNieddu91/Marlin-AI3M-BLTouch. Finally ...
0
votes
0answers
20 views

3D printer always resets after extruder jog

My 3D printer (Inventor 3D plus) using RAMPS1.4 with Arduino Mega using Marlin firmware (tweaked by manufacturer). I do preheat with hot end and heated bed then I jog with extruder motor. After I ...
0
votes
0answers
93 views

CreatBot DX firmware flash for BLTouch install?

Any resources to add a BLTouch to the CreatBot DX? I cant even get Marlin installed without bricking my LCD and USB. I've heard suggestions to flash Klipper, run everything from a Pi or to swap out ...
0
votes
0answers
17 views

CR-10 not printing properly after Marlin 2.0.x and BLTouch installation

I flashed a new version of Marlin (2.0.x) because I bought a BLTouch sensor on my Creality CR-10 v2. Ever since I did that, my printer has terrible first layers (adhesion) and layer strength is weak. ...
0
votes
1answer
783 views

UBL Marlin settings to cover whole bed

This question is related to: How to set Z-probe boundary limits in firmware when using automatic bed leveling? I am trying to figure out how to set UBL In Marlin to cover as much bed as possible. So ...
0
votes
1answer
34 views

Ender 5 SKR Mini E3 — After Heating the Hot End Assembly Runs into the side of the printer

So I got the SKR mini E3 for my Ender 5 after hearing all the positive reviews. When it arrives I plug everything in, make sure it's secure and test the axis... they all worked correctly. I then ...
0
votes
0answers
14 views

How to know which “TEMP_SENSOR_0” value for pre-built custom printer

I got a prebuilt custom printer which I am trying to get working. I am currently trying to configure Marlin for it and I am kind of stuck on the TEMP_SENSOR_0 ...
0
votes
0answers
463 views

Ender 3 Pro with BLTouch bed leveling stops after 1 test (Marlin 2.0.7.2)

I have an Ender 3 Pro with the BLTouch installed. Firmware is Marlin 2.0.7.2. I followed this instruction. When I start the bed leveling it will go to the center, check it twice and then return to the ...
0
votes
0answers
83 views

How to get strain gauge status

I've searched anywhere but couldn't find any single post on how to get strain gauge status from my Creality CR-6 SE. What I'd like to do is, if after first layer the strain gauge doesn't get any input ...
0
votes
0answers
102 views

Marlin inline void gcode_M400()

Can someone show me how to add Lines to Marlin 1.1.8 ? I want to change the M400 command. In a kind like that: ...
0
votes
0answers
14 views

Ultimaker 2 Extended+ temp input change

My Ultimaker 2 Extended+ motherboard has 3 temperature sensor inputs: Temp 1, Temp 2, Temp 3. The Temp 3 is for the bed and the Temp 1 and 2 are for 2 potential extruders. Now my printer has only one ...
0
votes
0answers
150 views

TMC2208,BMG and 0.9 degree stepper motor, is this a bad combination?

My printer randomly freezes partway into the print whenever I use the combination of Marlin 2.0, TMC2208 stealthchop, a 3:1 geared extruder and an E3D 0.9° stepper in a Bowden configuration on the E ...
0
votes
0answers
101 views

Marlin 1.1.9 mesh editing causes the nozzle to hit the bed and UBL is not correcting the leveling issues

ISSUE 1 The printer is having a physical bed size of 315 x 315 mm and there are 2 stepper motors that drive the extruder up and down. The 2 Z-steppers are synced and I already have a process to make ...
0
votes
0answers
47 views

Marlin 2.x on an SKR1.4 turbo - G29 is ignoring GRID_MAX_POINTS_X

Just installed a new SKR 1.4 turbo with Marlin 2.x I seem to be having an issue with G29. Configuration.h has these entries: ...
0
votes
0answers
65 views

3DTouch with heated bed UBL circular pattern bump

On my DIY Hypercube Evolution I have replaced plain aluminum heated bed with magnetic one for removing large prints off of it easier (blue tape makes it near impossible to remove them without damaging ...
0
votes
0answers
1k views

Error:Printer halted. kill() called! SKR 1.3 TFT35 3.0

I am trying to fix the very last error on my printer (custom built). Error:Printer halted. kill() called! This error occures about 5-10 minutes into a print (XYZ ...
0
votes
0answers
213 views

Marlin won't start up on modified CR10s

I have been adding a Hemera and BLTouch to my CR10s, and finally finished everything, flashed the firmware, and everything worked fine. However, I forgot about one thing (...
0
votes
0answers
27 views

Ender 3 Pro goes to one location on the bed and extrudes

I'm having trouble with my customized Ender 3 Pro. It's running an SKR v1.3 board with Marlin and OctoPrint on a Raspberry Pi 4. My problem is that sometimes when the printer goes to print, instead of ...
0
votes
0answers
101 views

BLTouch ender 3 pro doing a very hard end stop

I am very new to 3D printing and after finding the bed on my Ender 3 Pro to be very uneven I decided to install a bl-touch module and new firmware from TH3D. I use Cura and it works fine but it only ...
0
votes
0answers
473 views

Problem with temperature readings after Marlin upgrade

I have an Ender-3 that I've been using daily for almost 2 years. Yesterday, I updated the firmware to Marlin 1.1.9.1, using the configuration files provided for the Ender-3. I printed out a few ...
0
votes
0answers
62 views

Printer keeps pausing and restart during print process

I'm using Marlin bugfix 2.0.x with my custom printer. Sliced a test cube with PrusaSlicer 2.2.0. My printer starts printing ...
0
votes
0answers
107 views

Prints are Squished

My printer prints stuff okay but its all squished and much shorter than the model, My z Axis Esteps is fine I checked for loose wires and overheating but I can't figure it out. My Temp is 195, .15 ...
0
votes
0answers
163 views

RAMPS 1.4 LED 2 blinking when trying to heat up bed

On my i3 clone I've been trying to add the Anycubic i3 Ultrabase to my RAMPS 1.4 board and after adding the necessary configurations in the Marlin firmware I can heat up the bed. The issue is that it ...
0
votes
2answers
2k views

Z offset in Marlin is not working recently

My printer is ignoring the "Z offset" setting in Cura and the "Bed Z" stored in the printer LCD settings? It has been working before but after a firmware update of my printer, it ...
0
votes
0answers
104 views

Printer not processing G-code properly?

I have 3 printers, all Anet A8 with RAMPS 1.4 boards running identical firmware. One printer, however, has a Bowden extruder setup and RepRap 3 pin limit switches. Otherwise identical to the other 2 ...
0
votes
0answers
161 views

Printer froze mid print, stepper motor driver and MCU extremely hot afterwards. MCU seems dead now (?)

A strange problem occured while 3D printing. I've been printing for a long time now, and I consider myself fairly expeienced. normally, with every problem I've encountered with my printers (Anet, ...
0
votes
0answers
3k views

How to calculate the Vref and X_CURRENT for a TMC2130 stepper driver, knowing the rated current of the stepper motor?

I have written a question about this but I found new information in this video and I want to go more to the point. My motor "rated current" is 1.4V. I assume that this is the maximum current The guy ...
0
votes
0answers
70 views

Display/log tool temperature to higher resolution?

The default displayed and logged resolution of the tool temperature is to 1 decimal place. However, I noticed during autotuning the temperature is recorded to 2 decimal places. Is it possible to ...
0
votes
0answers
282 views

Stepper motors won't move on RAMPS 1.4

I have an Arduino Mega clone and RAMPS 1.4 together with A4988 drivers and NEMA 17 motors which won't move. Motors can be turned easily by hand both when the RAMPS is powered and is not powered. There ...
0
votes
0answers
30 views

Trying to remove autolevel from G-code - offset from bed not correct

I’ve been having all kinds of trouble with really every part of the print procedure on my Lulzbot Mini 2 that comes before the actual extrusion starts. I think I can get around 90 % of my issues ...
0
votes
0answers
477 views

SKR 1.3 Thermistor input died

I've got an SKR 1.3 and the thermistor input for extruder 2 has gone bad. In firmware, I've attempted to change the TEMP_1_PIN to another in ...
0
votes
0answers
50 views

LV8729 on kossel issues with print dimensions (steps)

I've installed the an LV8729 on a kossel, configured with SKR 1.3 and marlin 2.0 with all the jumpers configured in the same way for 16 micro steps for X Y Z axis. Everthing seems fine the printer ...
0
votes
0answers
226 views

Grayscale laser engraving with Ramp1.4

I have a Reprap Guru Prusa i3 v2 3D printer. To this I added a 5.5 W laser that I purchased online. The board of my 3D printer is an Arduino Mega 2560 board with Ramp 1.4. I have connected my laser ...

1
2