2022 Developer Survey is open! Take survey.

Questions tagged [ramps-1.4]

For questions specifically related to the RAMPS 1.4 controller board - The RepRap Arduino Mega Pololu Shield, or RAMPS for short, is an expansion shield for the Arduino Mega designed to fit the entire electronics for a RepRap 3D printer in a small, low cost package.

Filter by
Sorted by
Tagged with
0 votes
1 answer
70 views

Can I plug in Arduino Mega USB input (to supply power) and RAMPS 1.4 power input at the same time?

Can I plug Arduino Mega USB input (to supply power) and RAMPS 1.4 power input at the same time? This is because when I plug the PSU into the RAMPS 1.4 alone, the LCD keeps restarting and it just gets ...
user avatar
  • 11
0 votes
1 answer
59 views

Why is my PSU turning on and off automatically?

I have 12 V/30 A PSU. I have also installed the firmware onto the Arduino Mega2560. But the problem is that the display on the LCD keeps turning on and off automatically (it's stuck on the Marlin logo ...
user avatar
  • 11
0 votes
3 answers
43 views

Can I connect a PSU with a higher current rating than RAMPS 1.4 can handle?

I have a 12 V/30 A power supply. Will a RAMPS 1.4 shield burn if I use that power supply with it?
user avatar
  • 11
0 votes
1 answer
192 views

What is the maximum input ratings for current, voltage and power for RAMPS 1.4, 1.5 and 1.6?

I need to know the maximum input for current, voltage and power for: RAMPS 1.4 RAMPS 1.5 RAMPS 1.6 I want to build a DIY 3D printer. RAMPS 1.6 can deliver only 270 W. but if I total my heatbed + ...
user avatar
  • 11
0 votes
2 answers
95 views

Hotend temperature goes to infinity after few layers

I have a "classic" home built 3D printer, Arduino Mega, RAMPS 1.4 with Marlin 2.0. It worked, was put in storage, and now I am trying to get it running again. During all of the testing ...
user avatar
  • 101
0 votes
0 answers
54 views

Stepper motor running with pauses, driver problem

I am here sharing this problem that is happening to me. I have a printer mounted with Arduino and RAMPS 1.4 shield with A4988 drivers. I was trying to calibrate the printer when I came across a ...
user avatar
4 votes
1 answer
169 views

Marlin is restarting when pins 5 Vcc are enabled and has a servo motor connected (RAMPS 1.4)

My printer uses an ATMega 2560 with a RAMPS 1.4 shield, A4988 stepper drivers and a 2004 controller LCD interface. The PSU is 360 W (12 V, 30 A). I bought a BLTouch for my printer, but when installing,...
user avatar
  • 65
2 votes
1 answer
94 views

How to change pin of thermo sensor?

The thermoresistor on my Anycubic Mega displays nonsense temperatures (e.g. 700 °C), since the resistor in the hotend is working fine the problem is 100 % in the board (Trigorilla RAMPS 1.4). Someone ...
user avatar
1 vote
1 answer
96 views

Confusing stepper motor behavior

I am trying to control stepper motors for a 3D printer with a RAMPS 1.4 shield connected to an Arduino Mega 2560. I have uploaded Marlin firmware to the board and am currently using Pronterface to ...
user avatar
1 vote
1 answer
206 views

Problems with the right Z axis

My 3D printer was working perfectly, but one day I put it inside an acrylic box and put it to work, that was not a good idea, because the Z axis grabbed the box, after that, the Z axis started to ...
user avatar
0 votes
0 answers
55 views

Heated bed is not heating up

Hello I am building a clone of Prusa MK2. So I connected all the connections to the RAMPS 1.4 shield. I used Pronterface successfully to set the temperature of bed, but it did not heat up... So I ...
user avatar
0 votes
1 answer
1k views

Mixing nozzle vs dual nozzle vs IDEX vs tool changer for pva and pla

I am planning to build a 3D printer with dual extrusion. I want to use PVA with one of the extruders and the main material with the other one so color printing isn't important for me and I just want ...
user avatar
0 votes
1 answer
648 views

MOSFET burned and high heated bed resistance

I am a newbie to 3D printing and I am making a 3D printer from scratch (Cartesian). I've got a RAMPS 1.4 shield and an Arduino Mega 2560 board. I have a few questions and it would be very nice if I ...
user avatar
0 votes
1 answer
199 views

Three RAMPS boards wasted by plugging in a heated bed

I have a DIY 3D printer. Everything works fine except the heated bed. When I plug my heated bed to the D8 terminal smoke comes out. This is my third RAMPS board that I have had this problem with. ...
user avatar
1 vote
2 answers
480 views

CoreXY with 8 bit board problems

I know that CoreXY kinematics is very complex and hard to calculate for the firmware making it better to use a 32-bit board. For some reason, I can't use any 32-bit board. What problems will occur if ...
user avatar
0 votes
0 answers
194 views

Auto bed leveling with stepper motor lock

I have a botObject printer that was discontinued that I want to run using a RAMPS 1.4 board. The bed leveling was done by the print nozzle being pushed down on the spring loaded bed and then the ...
user avatar
0 votes
0 answers
228 views

RAMPS 1.4 LED 2 blinking when trying to heat up bed

On my i3 clone I've been trying to add the Anycubic i3 Ultrabase to my RAMPS 1.4 board and after adding the necessary configurations in the Marlin firmware I can heat up the bed. The issue is that it ...
user avatar
2 votes
1 answer
390 views

Which 3D printer controller should I use?

I recently build a 3D printer from scratch and was using an Arduino Mega + RAMPS 1.4 to control it. A few weeks in I installed a heated bed to help my prints stick to the surface. The bed I bought was ...
user avatar
0 votes
0 answers
388 views

Stepper motors won't move on RAMPS 1.4

I have an Arduino Mega clone and RAMPS 1.4 together with A4988 drivers and NEMA 17 motors which won't move. Motors can be turned easily by hand both when the RAMPS is powered and is not powered. There ...
user avatar
0 votes
1 answer
193 views

Makerbase MKS Slot2 V1.0 + RepRapDiscount Full Graphics LCD + RAMPS 1.4

I want to add an external SD card adapter on my RepRapDiscount Full Graphics LCD. My 3D printer is based on (Arduino Mega + RAMPS v1.4 + RepRapDiscount Full Graphics LCD). I buy an SD Card Adapter ...
user avatar
0 votes
0 answers
137 views

Stepper motors not working when connected to RAMPS 1.4

Stepper motors are not working when connected to RAMPS board in the X,Y,Z pins. I used A4988 drivers and the Arduino board is an original version. I checked the input voltage to the RAMPS board, it's ...
user avatar
  • 1
2 votes
1 answer
1k views

How to extend Marlin to support additional movement axis?

On a RAMPS 1.4 it is possible to mount 5 stepper motors: X,Y,Z steppers are used for ...
user avatar
3 votes
1 answer
2k views

Replacing RAMPS 1.4 for 1.6

During the assembly of my printer, I accidentally shorted the RAMPS 1.4 board, looking for a replacement I found the RAMPS 1.6 which would eliminate the need for a MOSFET power module. My question is,...
user avatar
  • 55
3 votes
1 answer
244 views

RAMPS 1.4 Stepper's not getting a good signal

Running on the Marlin 1.1 firmware, for this issue, most other variables of the printer can just be assumed (It's a CoreXY design, but think i3 for my current testing). (Highlighted my only lead in ...
user avatar
2 votes
1 answer
415 views

Marlin on Arduino Mega 2650 and RAMPS 1.4

I have been messing around trying to flash marlin 1.1 onto my Arduino Mega 2650 and RAMPS 1.4. I have Managed to get it to upload fine however it will not upload with the LCD I want. I am trying to ...
user avatar
5 votes
2 answers
1k views

Where did I go wrong by trying to add an extra motor to my board?

I'd like to add an extra motor to my board and I'm not sure where I went wrong. The motor will be used to spin a rotating wheel/carriage of potential hot ends to switch to. Because it's just a motor ...
user avatar
  • 1,560
4 votes
1 answer
404 views

Digital vs. analog pins

In the RAMPS v1.4 board, it seems like the X, Y, and Z motors all use at least one analog pin, while the extruder motors are entirely digital. See just the top left block of this photo: Is there any ...
user avatar
  • 1,560
2 votes
0 answers
209 views

Display locks when executing G-code for laser cutting using Marlin on RAMPS board

I'm working on a Laser cutter. I’m using the RAMPS 1.4 and Marlin software. To make the Marlin software work with a laser I’m inspired by this blog from dreammakercnc: Marlin Firmware modification for ...
user avatar
4 votes
1 answer
912 views

Laser LA03-5000 wiring to RAMPS 1.4

I'm totally lost. I have been searching about two days how to correctly wire Blue Laser LA03-5000 to RAMPS 1.4 board. This laser has 12 V input and separates PWM/TTL wires. I have found out how ...
user avatar
0 votes
0 answers
294 views

Grayscale laser engraving with Ramp1.4

I have a Reprap Guru Prusa i3 v2 3D printer. To this I added a 5.5 W laser that I purchased online. The board of my 3D printer is an Arduino Mega 2560 board with Ramp 1.4. I have connected my laser ...
user avatar
  • 183
6 votes
1 answer
987 views

Add a laser module to Reprap Guru Prusa i3

I have a Reprap Guru Prusa i3 v2 3D printer. Here is a link to the 192 MB manual. And here is the link to the resources page for the Reprap Guru. Page 58 of the manual discusses electronics. I ...
user avatar
  • 183
1 vote
1 answer
118 views

TMC2130 External VM RAMPS 1.4

I'm attempting to replace my DRV8825's with TMC2130's on a Prusa i3 rework clone, 12 V RAMPS 1.4, motor currents have been accounted for. Since they don't work as well with 12 V than with higher ...
user avatar
4 votes
1 answer
1k views

Pronterface not connecting ERROR: A device attached to the system is not functioning

I'm assembling a 3D printer with the RAMPS 1.4 shield (board) and an Arduino Mega. I have assembled the structure and the electronics (set drivers, placed the jumpers, connected stepper motors, etc.) ...
user avatar
5 votes
1 answer
558 views

4pin fan on RAMPS board - direct?

The question is simple - I have a RAMPS 1.4 running Marlin 1.1.9 with the three MOSFETs being used (end, fan, bed), but I'd like to have a couple other Marlin-controlled fans. One of them would be a 4-...
user avatar
4 votes
1 answer
515 views

How do I calibrate temperature control in a Repetier firmware?

I have built a 3D printer using RAMPS 1.4. I am trying to raise the hotend temperature over 180 °C. But I can hardly get to 100 °C in 60 minutes. I applied power directly to the ...
user avatar
4 votes
3 answers
12k views

After some time stepper motor is hot

I have three stepper motors. One Nema 17 - 2.4 ohm, the second smaller noname from color printer - 9.5 ohm and third the smallest noname from cdrom - 10.5 ohm. I have connected them to arduino mega ...
user avatar
  • 195
2 votes
1 answer
557 views

Connecting Anet 8 2004 display with Ramps 1.4 to Aux2 can't seem to figure it out [duplicate]

I've heard about switching out some connectors, but can't seem to figure out which ones and can't seem to find a diagram out there that is much help. Does anyone know which connectors I should switch ...
user avatar
4 votes
2 answers
1k views

Why did my power supply fuse blew out on my Anet A8?

So yesterday I got my power supply in the mail and I thought, let's check it out! I put all the wires in correctly (as shown in this YouTube video, Anet A8 power supply unit fuse blown, I just ...
user avatar
1 vote
2 answers
10k views

Bed Heating Failed, Printer Halted, Please Reset

A couple of weeks ago I have successfully built a 3D Printer and Printed an XYZ Calibration Cube with ABS material at bed temperature 80 °C. Next Day I tried bed heating at bed temperature 80 °C, ...
user avatar
3 votes
2 answers
939 views

Limit Switch problems on RAMPS 1.4 and custom built 3D Printer running Marlin 1.1.0-rc6

So I am trying to fix a custom built 3D printer for my institute and am running into a problem I can't wrap my head around. So the limit switches for Y-axis and Z-Axis work just fine, but the X-Axis ...
user avatar
5 votes
1 answer
4k views

How to test Arduino Mega, RAMPS 1.4 and Full Graphic Smart Controller LCD?

Unfortunately, my extruder 8825 driver ended up fried. I guess this might have damaged the Arduino Mega and RAMPS Board. I tested the Arduino Mega and I'm pretty sure that it is fried too, so I ...
user avatar
  • 541
2 votes
2 answers
3k views

RAMPS board - no power to heatbed

I'm setting up my first 3D Printer, a Prusa i3 MK2 clone. When I try to heat the bed, nothing happens. Then Marlin throws this error after a while: ...
user avatar
  • 151
6 votes
1 answer
675 views

Upgrading to silicone heat bed, will it burn my house down?

I'm looking into upgrading my heated bed and replacing it with a silicone bed. I know nearly nothing about electronics, so I would like someone more knowledgeable to confirm if what I have theorized ...
user avatar
3 votes
1 answer
250 views

Reprap RAMPs over heating issues

So I've got a couple problems, to begin I'm using the RAMPs 1.4, generic Arduino mega with Marlin, generic stepper motor drivers, a generic power supply. Nothing is special or even out of the ordinary....
user avatar
4 votes
2 answers
4k views

Stepper motors are not working when connected with RAMPS 1.4

ISSUE: Stepper motors are not working when connected with RAMPS 1.4. OBSERVATION: The LED lights(LED 2,3,4) in the RAMPS 1.4 is not powering up. PRACTICES: I use Arduino Mega 2560 and installed ...
user avatar
  • 171
4 votes
1 answer
205 views

MKS board losing power after endstop installation

I just bought an MKS gen v1.3, and everything on it works fine except for when I plug in the endstops. My X endstop works perfectly in every endstop outlet, but when I plug in my Z and Y endstops, the ...
user avatar
7 votes
1 answer
8k views

Controlling more fans with RAMPS board

I am using RAMPS 1.4 with Marlin. With Marlin, you can control a large number of fans with the M106 P<fan index> command. I'd like RAMPS to control some ...
user avatar
  • 172
3 votes
1 answer
318 views

RAMPS PLUS 2 and E1 socket problem (K200 Delta, but related to the PCB , not printer)

Total 3D printing newbie here, apologies in advance if my terminology is wrong. I have a dual head K200 delta printer with a heated bed which I put together 8 months ago, but gave up due to ...
user avatar
3 votes
3 answers
2k views

Z-Axis doesn't work only during printing

Problem: Z-Axis doesn't work during a print. It attempts to work, maybe climbs on the Z-Axis, but screws back down. It whines, too. But, Z-Axis DOES work while not printing. It doesn't matter if ...
user avatar
  • 61
4 votes
3 answers
995 views

Cooling fan spins extremely fast, noisy on startup

I have built a 3D printer from parts. It is using a standard 12V power supply, an Arduino Mega 2560 replica and a RAMPS 1.4 board. The hotend cooling fan is connected to the 12V-AUX pin (the one right ...
user avatar
  • 43