Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [ramps-1.4]

The RepRap Arduino Mega Pololu Shield, or RAMPS for short, is an expansion shield for the Arduino Mega designed to fit the entire electronics for a RepRap 3D printer in a small, low cost package.

6
votes
1answer
437 views

Upgrading to silicone heat bed, will it burn my house down?

I'm looking into upgrading my heated bed and replacing it with a silicone bed. I know nearly nothing about electronics, so I would like someone more knowledgeable to confirm if what I have theorized ...
3
votes
1answer
38 views

Reprap RAMPs over heating issues

So I've got a couple problems, to begin I'm using the RAMPs 1.4, generic Arduino mega with Marlin, generic stepper motor drivers, a generic power supply. Nothing is special or even out of the ordinary....
3
votes
2answers
245 views

Stepper motors are not working when connected with RAMPS 1.4

ISSUE: Stepper motors are not working when connected with RAMPS 1.4. OBSERVATION: The LED lights(LED 2,3,4) in the RAMPS 1.4 is not powering up. PRACTICES: I use Arduino Mega 2560 and installed ...
4
votes
1answer
42 views

MKS board losing power after endstop installation

I just bought an MKS gen v1.3, and everything on it works fine except for when I plug in the endstops. My X endstop works perfectly in every endstop outlet, but when I plug in my Z and Y endstops, the ...
6
votes
1answer
235 views

Controlling more fans with RAMPS board

I am using RAMPS 1.4 with Marlin. With Marlin, you can control a large number of fans with the M106 P<fan index> command. I'd like RAMPS to control some ...
3
votes
1answer
50 views

RAMPS PLUS 2 and E1 socket problem (K200 Delta, but related to the PCB , not printer)

Total 3D printing newbie here, apologies in advance if my terminology is wrong. I have a dual head K200 delta printer with a heated bed which I put together 8 months ago, but gave up due to ...
3
votes
3answers
136 views

Z-Axis doesn't work only during printing

Problem: Z-Axis doesn't work during a print. It attempts to work, maybe climbs on the Z-Axis, but screws back down. It whines, too. But, Z-Axis DOES work while not printing. It doesn't matter if ...
4
votes
2answers
109 views

Cooling fan spins extremely fast, noisy on startup

I have built a 3D printer from parts. It is using a standard 12V power supply, an Arduino Mega 2560 replica and a RAMPS 1.4 board. The hotend cooling fan is connected to the 12V-AUX pin (the one right ...
3
votes
1answer
196 views

Arduino WEMOS and RAMPS

I'm thinking of buying an Arduino WEMOS1 as I am tired with SD card fiddling. As the ESP8266 chip has 32 Mb (~4 MB) flash memory, I am hoping to be able to push most of the G-code files ...
4
votes
1answer
85 views

Laser Engraver with Smoothie, RAMPS 1.4 or AWC708C?

I have an old laser engraver that runs from Windows 98SE and DOS-6. Yup, still works fine but a pain as I regularly have to open it up and unplug and re-seat all the ribbon connectors. Fifteen of them ...
5
votes
2answers
207 views

Steps per mm of extruder are incorrect after rebuilding

I have got a problem that after upgrading my printer to an aluminum frame my extruder went from around 400 steps per mm at 16 micro steps (which did match the manufacturer's recommendation perfectly) ...
4
votes
2answers
91 views

Heated Bed not heating on original Prusa i3. Using a Ramps 1.4 EFB

So as the title said my heated bed stopped heating mid print. I'm pretty confident the bed itself is not the problem as I've ran continuity tests from the wires and a resistance check (which showed ...
4
votes
2answers
2k views

Configuring BLTouch with Marlin firmware

Has anyone configured BLTouch with Marlin firmware? I could only find videos about older firmware version. I followed this document. To avoid causing any damage to the printer, I removed all ...
8
votes
1answer
962 views

TMC2208 drivers - Microsteps configured incorrectly

I've just installed two TMC2208 drivers on my RAMPS board. I followed a very good step by step tutorial and after some issues, I got it nearly to work. One problem I still have is that when I tell ...
4
votes
4answers
327 views

Speeding up the heating of the heated bed

Currently I am using a 12 volts, 20 amperes power supply (Model S-240-12) The stepper motors and the extruder need 5 amp, and the heated bed build plate needs 11 amp. Technically you only need to ...
3
votes
2answers
228 views

Homing a stepper motor as an extruder using E0/E1 with an limit switch and end stop

Note: I have extended my question as some of you mentioned that the question is not clear. I am using a RAMPS 1.4 board with an Arduino mega 2560. I need to drive a stepper motor as an extruder using ...
4
votes
2answers
167 views

Ramps 1.4 with a power brick

I'm currently designing a RepRap 3D printer that will not have a heated bed. I have heard that it is possible to use a power brick with commercial printers lacking heatbeds. Is this possible with a ...
0
votes
1answer
23 views

Using ramps on-load [duplicate]

I have a RAMPS 1.4 with Arduino Mega 2560 with 2 steppers connected to an external power supply using Polulo stepper drivers. The steppers are for X and Y axis movement. This external power supply is ...
2
votes
1answer
218 views

Can I use external stepper motor power and USB connection

I have a RAMPS 1.4 with Arduino Mega 2560 with 2 steppers connected to an external power supply using Polulo stepper drivers. The steppers are for X and Y axis movement. This external power supply is ...
3
votes
2answers
468 views

Weird Movement and not homing

https://photos.app.goo.gl/O6yPf3sDeV1yhS0C2 I tried to illustrate my problem in the videos above, two of them show the weird movement and the other shows me clicking on the home button repeatedly. ...
4
votes
1answer
571 views

Plug sdramps module and Anet A8 LCD together into RAMPS smart adapter

I want to upgrade my Anet A8's motherboard (the stock one is broken anyway, see: Anet A8 reading 739°C from the extruder thermistor!) to the RAMPS 1.4, without having to get a new LCD/microSD ...
3
votes
1answer
421 views

How should I connect RAMPS 1.4 with an Nema motor?

I have an Nema17 stepper motor 17HS4401 and a RAMPS 1.4 driver unit. The motor pinouts are: ...
5
votes
2answers
4k views

RAMPS 1.4, 1.5 or 1.6?

I'm about to build a Prusa i3 dolly. I am confused whether to use RAMPS 1.4 or 1.5 or 1.6. What is the big difference? Is it only the MOSFETs and the poly-fuses? If that is the case, would it be ...
7
votes
2answers
64 views

RAMPS won't PID tune and shows unreal temps

About two days ago, I started seeing that my hotend was heating up erratically. I first noticed this while printing a part in PETG and the temp jumped to 260 °C. I shut down the printer at that ...
5
votes
2answers
303 views

Filament starts extruding as soon as hotend reaches melting point

I have a homemade 3D printer running on ramps 1.4 When i start a new print and the hotend reaches melting point of PLA, the PLA start coming out of the hotend. This goes on for as long as the ...
3
votes
1answer
58 views

Printing Chocolate with Ramps 1.4

Is it possible to print chocolate or food using Ramps 1.4? I have seen printers that are capable of printing food. But I am not sure if there is one that is open source. Does any of you have any ...
5
votes
1answer
855 views

Z axis Stepper motors not working correctly

I have been searching around the internet for the last 3 days trying to figure this out. My Z axis motors for a pursa-i3 3d printer are not working correctly. I have marlin firmware and using repetier ...
2
votes
1answer
3k views

How to configure Marlin to enable auto-fans with dual extruder

I have successfully assembled my 3D printer and configured Marlin for two extruders and one heated bed. Here is a picture of the printer. My heated bed runs on a linear axis with ball bearings. When ...
1
vote
1answer
60 views

Z motors work synchronously ToyRep

I have a problem with Z direction. As you know it has two motors. And my problem is that one sometimes goes to the different direction (so basically one is screwing and another one unscrewing). It is ...
2
votes
2answers
85 views

Double Image Along X Axis

Recently my printer has been creating double images along the X-axis, I just printed a calibration cube after checking all of my rods to make sure nothing was catching and here was my result: It ...
3
votes
2answers
114 views

Y-axis slipping causing failed prints

My Y-axis on my Monoprice maker select running ramps 1.4 and Marlin makes a thud noise when moving every now and then. I have noticed a 1 to 2 mm shift in the print when this occurs. I tighten the ...
4
votes
1answer
192 views

RAMPS 1.4 losing power with more than 3 drivers mounted

I am rebuilding the electronics for an old Reprap with a RAMPS 1.4 setup. If I plug in just the Arduino/RAMPS board into either 12 V or USB then it starts up fine, I can see this when I have ...
6
votes
1answer
550 views

Z motor not moving during auto home

My Monoprice maker select recently fried its melzi board. So I went out and purchased a ramps 1.4 kit. I've wired it all up and Flash the firmware with marlin(most recent build). When it boots up ...
4
votes
1answer
359 views

Step motors vibrate, don't move at all (Prusa I3)

Recently, I changed my RAMPS 1.4 card (because there was a problem with the power output).So I bought this new one, and an Arduino Mega.I didn'T change the code (Marlin 1.3.3).I used the same ...
3
votes
3answers
656 views

Temperature problems after switching to RAMPS 1.4

I recently switched to a RAMPS 1.4 on an Arduino Mega 2560. Ever since I have extruder temperature swings a couple of minutes into the print, but it looks like a problem reading the temp rather than ...
1
vote
2answers
538 views

Is my 5A polyfuse on my RAMPS board bad?

My printer stopped printing during a few prints, and i found that the extruder had stopped heating, and the motors had stopped running. I checked the code, and nothing was wrong. My 5A fuse though, ...
4
votes
4answers
731 views

Running laser on my printer

I am trying to control a laser with the fan (D9) and ran into problems. So I tried P44, no good then P6 also not good.\ What my problem is I am trying to "burn" a group of vertical lines spaced about ...
4
votes
1answer
419 views

Z axis issue with Ramps 1.4

I just installed a Ramps 1.4 board on to my Anet A8. Everything worked as it should except for the Z axis motors. The Ramps board I have contains two headers for each Z axis motor. When both motors ...
4
votes
1answer
136 views

Printrun doesn't connect when 12 V is on

I'm able to connect to Arduino+RAMPS through USB. I can even check end stops with M119. However, if I plug it to the power supply, my MacBook goes crazy and restart ...
4
votes
1answer
509 views

What does Marlin's G30 code do?

I'm using Marlin 1.1.0RC8 to control an MPCNC, using a RAMPS1.4. We've just added a touch-plate to do Z-probing, which works nicely for a single probe (I just want calibrated height for variant bit-...
4
votes
2answers
749 views

Z axis at print is lower than when I home

I replaced the controller board in my Monoprice Select Mini with an Arduino/Ramps setup and compiled an uploaded Marlin 1.1.0-RC8 to run it. I've got most everything calibrated and working with one ...
3
votes
1answer
324 views

3D printer test troubles (M999 error, motors do not move)

I've been recently building a 3D printer and I'm having issues testing it. This is my hardware: RAMPS 1.4 Arduino Mega 2560 4x Pololu Motor shields A4988 1x Nema 17 extruder 2x floppy stepper motor ...
4
votes
2answers
105 views

How drastic is reversing the polarity of the power supply to a RAMPS board?

If I accidentally reverse the polarity of my power supply to the RAMPS board, what exactly will be damaged? Will it harm my: RAMPS; Arduino Mega; Stepper motor and/or drivers, or; Any other ...
3
votes
1answer
524 views

Has anyone used a Shield Buddy (en lieu of a Arduino Mega2560) as the RAMPS 1.4 host board?

I have read a few times1 that the Arduino Mega can struggle to perform the tasks required for 3D printer control, as the AVR chip is working at its limits, and this is why some manufacturers have ...
2
votes
1answer
772 views

Why am I not seeing an effect from an M42 command on Marlin?

I'm trying to use one of the RAMPS GPIOs to control an external device that requires a 5V low-current logic level signal from Marlin. In order to do this programmatically, my host software (Octoprint) ...
4
votes
2answers
2k views

Arduino Mega voltage regulator overheats with RAMPS board

This is my problem: I'm assembling a 3D printer with the RAMPS 1.4 board and Arduino Mega. I have assembled the structure and the electronics (set drivers, placed the jumpers, connected stepper ...
8
votes
1answer
3k views

Endstops will not trigger using Marlin Firmware

I have an old Solidoodle 2 that I bought broken from a garage sale that I am converting to use RAMPS 1.4 with Marlin Firmware. All the motors work correctly, I am just having issues getting the ...
4
votes
1answer
203 views

Connecting Sain Smart Mechanical End Stops to Ramps 1.4?

I have Sainsmart Mechanical End Stops, and I'm building a Prusa i3 Rework. I've recently gotten the x-axis to move, but it needs to stop when it gets to the end and it does not do that; I end up ...
5
votes
1answer
52 views

Should I comment out the code for what I am not testing when loading the test firmware for Ramps 1.4?

You may want to use this code to test all the electronics before installing any of the suggested firmwares. I'm planning on: Flashing the test firmware onto the Arduino Mega 2560, then unplugging ...
4
votes
2answers
455 views

Is there any opensource software that controls the RAMPS RepRap board directly from the computer?

I'd like to find an opensource software that communicates directly with the RAMPS board (or any other 3D printer driver) without using the arduino... It doesn't matter if it runs on Windows or linux ...