Questions tagged [ramps-1.4]

For questions specifically related to the RAMPS 1.6 controller board - The RepRap Arduino Mega Pololu Shield, or RAMPS for short, is an expansion shield for the Arduino Mega designed to fit the entire electronics for a RepRap 3D printer in a small, low cost package.

Filter by
Sorted by
Tagged with
8
votes
2answers
10k views

How do I wire the z-axis motors in parallel on the Prusa i3?

There is a little circuit board, or breadboard or something in the diagram of the wiring for the i3. And it's mentioned that the z-axis motors need to be wired in parallel but beyond that they don't ...
1
vote
1answer
97 views

TMC2130 External VM RAMPS 1.4

I'm attempting to replace my DRV8825's with TMC2130's on a Prusa i3 rework clone, 12 V RAMPS 1.4, motor currents have been accounted for. Since they don't work as well with 12 V than with higher ...
0
votes
2answers
79 views

Hotend temperature goes to infinity after few layers

I have a "classic" home built 3D printer, Arduino Mega, RAMPS 1.4 with Marlin 2.0. It worked, was put in storage, and now I am trying to get it running again. During all of the testing ...
1
vote
1answer
57 views

Confusing stepper motor behavior

I am trying to control stepper motors for a 3D printer with a RAMPS 1.4 shield connected to an Arduino Mega 2560. I have uploaded Marlin firmware to the board and am currently using Pronterface to ...
9
votes
3answers
11k views

Endstops will not trigger using Marlin Firmware

I have an old Solidoodle 2 that I bought broken from a garage sale that I am converting to use RAMPS 1.4 with Marlin Firmware. All the motors work correctly, I am just having issues getting the ...
1
vote
1answer
108 views

Problems with the right Z axis

My 3D printer was working perfectly, but one day I put it inside an acrylic box and put it to work, that was not a good idea, because the Z axis grabbed the box, after that, the Z axis started to ...
0
votes
0answers
46 views

Stepper motor running with pauses, driver problem

I am here sharing this problem that is happening to me. I have a printer mounted with Arduino and RAMPS 1.4 shield with A4988 drivers. I was trying to calibrate the printer when I came across a ...
1
vote
2answers
9k views

Bed Heating Failed, Printer Halted, Please Reset

A couple of weeks ago I have successfully built a 3D Printer and Printed an XYZ Calibration Cube with ABS material at bed temperature 80 °C. Next Day I tried bed heating at bed temperature 80 °C, ...
4
votes
1answer
75 views

Marlin is restarting when pins 5 Vcc are enabled and has a servo motor connected (RAMPS 1.4)

My printer uses an ATMega 2560 with a RAMPS 1.4 shield, A4988 stepper drivers and a 2004 controller LCD interface. The PSU is 360 W (12 V, 30 A). I bought a BLTouch for my printer, but when installing,...
4
votes
6answers
4k views

Speeding up the heating of the heated bed

Currently I am using a 12 volts, 20 amperes power supply (Model S-240-12) The stepper motors and the extruder need 5 amp, and the heated bed build plate needs 11 amp. Technically you only need to ...
2
votes
1answer
40 views

How to change pin of thermo sensor?

The thermoresistor on my Anycubic Mega displays nonsense temperatures (e.g. 700 °C), since the resistor in the hotend is working fine the problem is 100 % in the board (Trigorilla RAMPS 1.4). Someone ...
9
votes
1answer
8k views

How to configure Marlin to enable auto-fans with dual extruder

I have successfully assembled my custom-built 3D printer and configured Marlin for two extruders and one heated bed. Here is a picture of the printer. My heated bed runs on a linear axis with ball ...
3
votes
2answers
845 views

Limit Switch problems on RAMPS 1.4 and custom built 3D Printer running Marlin 1.1.0-rc6

So I am trying to fix a custom built 3D printer for my institute and am running into a problem I can't wrap my head around. So the limit switches for Y-axis and Z-Axis work just fine, but the X-Axis ...
4
votes
4answers
2k views

Temperature problems after switching to RAMPS 1.4

I recently switched to a RAMPS 1.4 on an Arduino Mega 2560. Ever since I have extruder temperature swings a couple of minutes into the print, but it looks like a problem reading the temp rather than ...
4
votes
3answers
807 views

Cooling fan spins extremely fast, noisy on startup

I have built a 3D printer from parts. It is using a standard 12V power supply, an Arduino Mega 2560 replica and a RAMPS 1.4 board. The hotend cooling fan is connected to the 12V-AUX pin (the one right ...
0
votes
0answers
21 views

3D printer always resets after extruder jog

My 3D printer (Inventor 3D plus) using RAMPS1.4 with Arduino Mega using Marlin firmware (tweaked by manufacturer). I do preheat with hot end and heated bed then I jog with extruder motor. After I ...
0
votes
0answers
52 views

How to power RAMPS 1.4 if no heated bed is used?

I bought a new RAMPS 1.4, Arduino Mega 2560, a new PSU 12 V 20 A, not using a heated print bed. The 5 A terminal in RAMPS 1.4 only draw as many amps as it needs (which is 5 A?) .So my question is: &...
0
votes
0answers
115 views

Stepper motors not working when connected to RAMPS 1.4

Stepper motors are not working when connected to RAMPS board in the X,Y,Z pins. I used A4988 drivers and the Arduino board is an original version. I checked the input voltage to the RAMPS board, it's ...
0
votes
0answers
46 views

Heated bed is not heating up

Hello I am building a clone of Prusa MK2. So I connected all the connections to the RAMPS 1.4 shield. I used Pronterface successfully to set the temperature of bed, but it did not heat up... So I ...
0
votes
1answer
818 views

Mixing nozzle vs dual nozzle vs IDEX vs tool changer for pva and pla

I am planning to build a 3D printer with dual extrusion. I want to use PVA with one of the extruders and the main material with the other one so color printing isn't important for me and I just want ...
0
votes
1answer
435 views

MOSFET burned and high heated bed resistance

I am a newbie to 3D printing and I am making a 3D printer from scratch (Cartesian). I've got a RAMPS 1.4 shield and an Arduino Mega 2560 board. I have a few questions and it would be very nice if I ...
0
votes
1answer
106 views

Three RAMPS boards wasted by plugging in a heated bed

I have a DIY 3D printer. Everything works fine except the heated bed. When I plug my heated bed to the D8 terminal smoke comes out. This is my third RAMPS board that I have had this problem with. ...
1
vote
2answers
337 views

CoreXY with 8 bit board problems

I know that CoreXY kinematics is very complex and hard to calculate for the firmware making it better to use a 32-bit board. For some reason, I can't use any 32-bit board. What problems will occur if ...
0
votes
2answers
643 views

Arduino and Ramps powering up [closed]

I want to run two stepper motors using Arduino Mega 2560 and RAMPS 1.4. But, somehow I burned the Arduino while I was connecting the motor and plugging the board to the computer. Can I plug external ...
10
votes
2answers
11k views

TMC2208 drivers - Microsteps configured incorrectly

I've just installed two TMC2208 drivers on my RAMPS board. I followed a very good step by step tutorial and after some issues, I got it nearly to work. One problem I still have is that when I tell the ...
0
votes
0answers
144 views

Auto bed leveling with stepper motor lock

I have a botObject printer that was discontinued that I want to run using a RAMPS 1.4 board. The bed leveling was done by the print nozzle being pushed down on the spring loaded bed and then the ...
0
votes
0answers
176 views

RAMPS 1.4 LED 2 blinking when trying to heat up bed

On my i3 clone I've been trying to add the Anycubic i3 Ultrabase to my RAMPS 1.4 board and after adding the necessary configurations in the Marlin firmware I can heat up the bed. The issue is that it ...
2
votes
0answers
188 views

Display locks when executing G-code for laser cutting using Marlin on RAMPS board

I'm working on a Laser cutter. I’m using the RAMPS 1.4 and Marlin software. To make the Marlin software work with a laser I’m inspired by this blog from dreammakercnc: Marlin Firmware modification for ...
3
votes
2answers
1k views

Homing a stepper motor as an extruder using E0/E1 with an limit switch and end stop

Note: I have extended my question as some of you mentioned that the question is not clear. I am using a RAMPS 1.4 board with an Arduino mega 2560. I need to drive a stepper motor as an extruder using ...
2
votes
1answer
310 views

Which 3D printer controller should I use?

I recently build a 3D printer from scratch and was using an Arduino Mega + RAMPS 1.4 to control it. A few weeks in I installed a heated bed to help my prints stick to the surface. The bed I bought was ...
4
votes
1answer
3k views

How to connect a NEMA 17 stepper to RAMPS 1.4?

I have an NEMA 17 stepper motor 17HS4401 and a RAMPS 1.4 driver unit. The motor pinouts are: ...
0
votes
1answer
146 views

Makerbase MKS Slot2 V1.0 + RepRapDiscount Full Graphics LCD + RAMPS 1.4

I want to add an external SD card adapter on my RepRapDiscount Full Graphics LCD. My 3D printer is based on (Arduino Mega + RAMPS v1.4 + RepRapDiscount Full Graphics LCD). I buy an SD Card Adapter ...
0
votes
0answers
290 views

Stepper motors won't move on RAMPS 1.4

I have an Arduino Mega clone and RAMPS 1.4 together with A4988 drivers and NEMA 17 motors which won't move. Motors can be turned easily by hand both when the RAMPS is powered and is not powered. There ...
5
votes
2answers
3k views

Steps per mm of extruder are incorrect after rebuilding

I have got a problem that after upgrading my printer to an aluminum frame my extruder went from around 400 steps per mm at 16 micro steps (which did match the manufacturer's recommendation perfectly) ...
7
votes
1answer
3k views

Z motor not moving during auto home

My Monoprice maker select recently fried its melzi board. So I went out and purchased a ramps 1.4 kit. I've wired it all up and Flash the firmware with marlin(most recent build). When it boots up ...
3
votes
1answer
99 views

Printing Chocolate with Ramps 1.4

Is it possible to print chocolate or food using Ramps 1.4? I have seen printers that are capable of printing food. But I am not sure if there is one that is open source. Does any of you have any ...
4
votes
1answer
345 views

Digital vs. analog pins

In the RAMPS v1.4 board, it seems like the X, Y, and Z motors all use at least one analog pin, while the extruder motors are entirely digital. See just the top left block of this photo: Is there any ...
6
votes
1answer
827 views

Add a laser module to Reprap Guru Prusa i3

I have a Reprap Guru Prusa i3 v2 3D printer. Here is a link to the 192 MB manual. And here is the link to the resources page for the Reprap Guru. Page 58 of the manual discusses electronics. I ...
2
votes
1answer
1k views

How to extend Marlin to support additional movement axis?

On a RAMPS 1.4 it is possible to mount 5 stepper motors: X,Y,Z steppers are used for ...
5
votes
2answers
974 views

Where did I go wrong by trying to add an extra motor to my board?

I'd like to add an extra motor to my board and I'm not sure where I went wrong. The motor will be used to spin a rotating wheel/carriage of potential hot ends to switch to. Because it's just a motor ...
3
votes
1answer
2k views

Replacing RAMPS 1.4 for 1.6

During the assembly of my printer, I accidentally shorted the RAMPS 1.4 board, looking for a replacement I found the RAMPS 1.6 which would eliminate the need for a MOSFET power module. My question is,...
9
votes
3answers
3k views

Tips for not burning out my Arduino Mega or catching something on fire when wiring a Prusa i3?

I'm reading about wiring up the electronic components to my Prusa i3 using an Arduino Mega 2650 and Ramps 1.4. I have step sticks, a heated bed, and a Switching Power Supply 12v Dc 30a 360w (more ...
3
votes
1answer
208 views

RAMPS 1.4 Stepper's not getting a good signal

Running on the Marlin 1.1 firmware, for this issue, most other variables of the printer can just be assumed (It's a CoreXY design, but think i3 for my current testing). (Highlighted my only lead in ...
2
votes
1answer
367 views

Marlin on Arduino Mega 2650 and RAMPS 1.4

I have been messing around trying to flash marlin 1.1 onto my Arduino Mega 2650 and RAMPS 1.4. I have Managed to get it to upload fine however it will not upload with the LCD I want. I am trying to ...
5
votes
2answers
2k views

What does Marlin's G30 code do?

I'm using Marlin 1.1.0RC8 to control an MPCNC, using a RAMPS1.4. We've just added a touch-plate to do Z-probing, which works nicely for a single probe (I just want calibrated height for variant bit-...
4
votes
1answer
806 views

Laser LA03-5000 wiring to RAMPS 1.4

I'm totally lost. I have been searching about two days how to correctly wire Blue Laser LA03-5000 to RAMPS 1.4 board. This laser has 12 V input and separates PWM/TTL wires. I have found out how ...
0
votes
0answers
264 views

Grayscale laser engraving with Ramp1.4

I have a Reprap Guru Prusa i3 v2 3D printer. To this I added a 5.5 W laser that I purchased online. The board of my 3D printer is an Arduino Mega 2560 board with Ramp 1.4. I have connected my laser ...
4
votes
1answer
1k views

Pronterface not connecting ERROR: A device attached to the system is not functioning

I'm assembling a 3D printer with the RAMPS 1.4 shield (board) and an Arduino Mega. I have assembled the structure and the electronics (set drivers, placed the jumpers, connected stepper motors, etc.) ...
4
votes
2answers
1k views

Why did my power supply fuse blew out on my Anet A8?

So yesterday I got my power supply in the mail and I thought, let's check it out! I put all the wires in correctly (as shown in this YouTube video, Anet A8 power supply unit fuse blown, I just ...
3
votes
1answer
416 views

4pin fan on RAMPS board - direct?

The question is simple - I have a RAMPS 1.4 running Marlin 1.1.9 with the three MOSFETs being used (end, fan, bed), but I'd like to have a couple other Marlin-controlled fans. One of them would be a 4-...