3
$\begingroup$

Just starting with octoprint.

  • Bought a pi3A+,

  • Etched a 4Go micro sd card with the latest octopi distro (0.17.0)

  • Using a 5V bench power supply that delivers up to 10A.

  • Following official octopi instructions

I managed to connect once my pi to the wifi, configured it, but as soon as I reboot my pi, it won't connect to the wifi again.

Any hints?

Nothing helped me in the wifi troobleshooting FAQ.

I thought that I changed a particular config but :

  • without configuration change, I:
    • started the pi once
    • waited until the pi connects to the wifi
    • successfully pinged the pi via my PC
    • rebooted the pi
    • a new ping wouldn't work
  • I compared the files on the boot partition and only this changed:
    • freshly etched sd card:
      • cmdline.txt:
      • console=serial0,115200 console=tty1 root=PARTUUID=6c586e13-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet init=/usr/lib/raspi-config/init_resize.sh
    • card from rebooted device:
      • cmdline.txt:
      • console=serial0,115200 console=tty1 root=PARTUUID=6c586e13-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

there is no more differences.

$\endgroup$
  • $\begingroup$ Welcome to 3dPrinting.SE! It sounds to me as though you inadvertently changed the WiFi settings. I'd go back through them and ensure they are now setup correctly. Don't assume everything is set right, make sure they are set right. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Dec 8 '19 at 13:43
  • $\begingroup$ I checked the octopi-wpa-supplicant.txt and it is unmodified...Which fil are you talking about? I even tried to change the wifi settings in the raspi-config $\endgroup$ – Guillaume D Dec 8 '19 at 13:45
  • $\begingroup$ I'm not entirely sure as I'm not familiar with those settings for either you pi or the computer you're using. What I'm getting at is something you changed when you configured your pi has caused the WiFi to stop connecting. Go back to those changes and you'll most likely find the issue. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Dec 8 '19 at 14:11
  • $\begingroup$ see my edit, what can i do i just the reboot change the config? $\endgroup$ – Guillaume D Dec 8 '19 at 15:15
0
$\begingroup$

What worked for me:

  • changed SD card from 2 GB to 16 GB (do not need so much)
  • power the pi with 5.4 V instead of 5 - 5.1 V
| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.