I've recently gotten into Resin 3d printing with a refurbished Elegoo Mars 1 but I've run into a weird bug where the printer would not expose any resin to the LCD.

I tested it by taking off the build plate and basin and looked at the LCD when it was exposing the layers. I've tried updating the firmware and tested about 20 odd prints of various sizes and detail. With those I saw that prints with large individual layers essentially stopped the LCD entirely (The exposure would flash on the LCD for a second then the LCD would not turn on again until I completely restarted the printer). What is more bizarre is that the first test print I did worked perfectly and still does for some reason (which was the tugboat and a random miniature).

For specific printer details I have an Elegoo Mars with the C type motherboard. There are no burn marks on the wiring or circuits and the LCD screen was replaced recently with a brand new one. And nothing is misaligned or unplugged. I even double checked that the LCD was still functional with the test exposure tools on the printer.

From my observations it is a data streaming issue with how it is connected with the USB drive. But that is a software issue that I am not capable of knowing.

Any ideas on what could be wrong or if this has happened before?

EDIT: Discovered that the Firmware needed to be updated to the latest version. Also, after testing out several very different print files the original print file that was having this issue was corrupted in some way as rebuilding it and printing the new version more or less worked. I also did another go around with cleaning everything and making sure that both the plate was level/tightened, FEP replaced, and that there was no IPA leftover on either.

  • 1
    $\begingroup$ Just a few suggestions. Maybe try updating the firmware. Even if it is up to date, reinstalling it may help fix a corrupted firmware. Maybe also put the slicer on an entirely different laptop or computer and slice it from there. It could very well just be a slicing bug. $\endgroup$
    – F.Ahmed
    May 11 at 23:24
  • $\begingroup$ I never thought about using my laptop. I'll try that out in the morning along with reinstalling the firmware $\endgroup$ May 12 at 2:29

2 Answers 2


I've tried updating the firmware...

aaand here is most likely your problem. Your Firmware update most likely did not handle properly, resulting in a corrupted firmware. Reinstallation of the firmware might be in order.

You might want to test a different USB drive, in case it is a problem with just that specific dongle. Sometimes a USB stick might be ill-formatted or too large to allow running an update.

To verify it is a problem with the USB driver, in many machines one could also slice a model, connect to the printer via a cable and print directly from the computer's slicer. If the problem is the USB port, then this should print properly, but it is not always an option.

  • $\begingroup$ Sadly, the mars doesn't have the capability or port to be connected directly to a computer. The firmware also refuses to update. It will say that it does but the version doesn't change. $\endgroup$ May 12 at 20:09
  • 2
    $\begingroup$ UPDATE: I dug deep into several other websites and found out that I had to partition my newer 32gb usb with a FAT32 4096 partition and only put the .SH4 .CBD and .TXT files in the root. Then the firmware finally updated. $\endgroup$ May 12 at 20:34
  • $\begingroup$ Ah yes, the classical "That can't be, the stick's too big!" $\endgroup$
    – Trish
    May 12 at 20:36

Resin particles or residues can accumulate on the LCD screen, hindering its proper operation. Check that the connection cables are not loose or damaged.

Before performing a firmware update, I suggest making a backup.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .