2
$\begingroup$

I have an FLSun 3D Cube, running off an MKS GEN V.1.4 main board. With Marlin 1.0, the Z-axis works great (and has been for three years). When I try to upgrade to Marlin 2.0, moving the Z-axis 10 mm results in extreme motion -50 mm at least, left motor then the right motor, three or four times, very fast. It's loud, it's jarring, and it's at the very least incorrect.

What setting am I missing?

$\endgroup$
2
  • 1
    $\begingroup$ Are you sure the steps/mm are indentical between your configurations? Too high values for Z max speed or Z acceleration might also cause odd behaviour. $\endgroup$
    – towe
    Sep 28 '20 at 5:39
  • $\begingroup$ Are you using Marlin 2.0 correctly configured for your printer? If it's configured for a different printer, anything can happen. Where did you get the Marlin 2.0 image? $\endgroup$
    – DoxyLover
    Sep 28 '20 at 6:52
2
$\begingroup$

I believe (from reference) the default steps per mm for the FLSUN 3D Cube are:

                                          X,   Y,    Z, E0 
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 100, 100,  400, 150 }

Default marlin 2.0.x are:

                                          X,   Y,    Z, E0 
#define DEFAULT_AXIS_STEPS_PER_UNIT   {  80,  80, 4000, 500 }

Such a setting would explain the excessive speeds; while the printer only needs 400 steps for advancing a single millimeter, the stepper receives 4000, this implies a tenfold, hence larger displacement and higher speeds.

$\endgroup$
1
  • $\begingroup$ That's what I was missing. Thank you very much. $\endgroup$ Sep 29 '20 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.