3
$\begingroup$

I made two updates to my Ender 3 Pro: Silent Mainboard and BLTouch. My printer head is way out of sync now. After I Auto Home, it moves along the X-axis to the left, hits the stop switch & moves back to the right. It does not move at all on the Z-axis and remains 3 - 4" above the bed during and after Auto Homing.

Here's the detail :

I installed a Creality Ender 3 Pro New Upgrade Motherboard Silent Mainboard V4.2.7 with TMC2225 Driver Marlin 2.0.1 & bootloader pre-installed & then a Creality BLTouch 3D Printer Upgraded Auto Bed Leveling Sensor Kit (the kit that comes from Creality with everything you need to install). I imagine I attempted too many upgrades without verifying the printer worked properly when I did the first upgrade which was the mainboard?

I purchased this Ender 3 Pro back in April 2020. It was working great until I decided to make the upgrades. I assume it came with an 8-bit board but not 100% sure. The new board is 32-bit and not sure what that would negatively impact besides maybe the LCD screen which does work fine after the upgrade.

Here's a video of the printer attempting to Auto Home :  


Note: Disregard the unhooked cable under the printer bed in the video.  It is totally disconnected and leftover from the BLTouch install.

Here's how I did the upgrade :

First, I simply replaced the new mainboard, and with the mainboard cover and fan back in place, I powered the printer on. The only thing I did here was to verify that the printer would power up ok. It powered up just fine. The nozzle head did not move I don't think when powered on.

Next, I followed the instructions for the BLTouch that came with the kit. I followed the instructions for the Creality V1 Mainboard 32-bit. Here, I upgraded the firmware via an SD card as suggested. The firmware I upgraded to is the Ender-3 Pro_4.2.7_BLTouch_Marlin2.0.1_V1.1.2_TMC2225.bin. Finally, I powered on the printer with the BLTouch plugged in and new firmware installed. The BLTouch lights up and the touch sensor clicks out and in and few times.

Now, when I hit auto home the nozzle head moves like I described above & remains in a position that I can not attempt to print from. I attempted to follow step #6 Platform adjustment 32-bit, working through the screenshots in the instructions. This did not work.

If helpful, here are the positions of the nozzle head during the two upgrades :

  • Position of the print head before install: 3-4 inches above the bed and maybe a little off-center on the X-axis.

  • Position after install mainboard upgrade: remained the same as before. I just remember it powering on ok and then I turned it off / unplugged power to start installing the BLTouch.

Position after install of BLTouch: remained the same. BLTouch lights up and the sensor tip moved in and out as if it was checking something or verifying it was working.

I'm a bit lost on this issue. Any help will be greatly appreciated!


I'm using 3D4LYF's wiring scheme as I'm using the same set up I believe he is using. The two wires (white & black) on the red connector go in the Z-axis endstop port on the mainboard. For the three wires on the black connector I have: blue=Ground, red=V, yellow=IN that goes in the other 5 pin port on the mainboard. I rearranged the wiring from red/blue/yellow to blue/red/yellow as suggested by 3D4LYF again because I am using the BLTouch Creality Kit. Adding photos of 5-pin port and the connectors:

enter image description here enter image description here

$\endgroup$
8
  • $\begingroup$ Could be as simple as a controller board that arrived broken, hard to tell. Maybe you could go back to the old board first, then test the BLTouch on that and finally move to the new board. $\endgroup$ – 0scar Mar 6 at 0:07
  • $\begingroup$ Unfortunately I fried my old board trying to follow Teaching Tech on youtube. $\endgroup$ – wallwalker Mar 6 at 20:08
  • $\begingroup$ The video shows typical behavior of a sensor that: A) is not properly connected or setup, or, B) is not properly functioning because of a hardware failure. Install the new board without the BLTouch first. $\endgroup$ – 0scar Mar 6 at 23:22
  • $\begingroup$ @wallwalker How did you fry your board? I installed BLTouches on both my machines following Teaching Tech's video and have had no problem. It is unusual to fry a mainboard with firmware changes. $\endgroup$ – HotGlue Mar 7 at 5:58
  • $\begingroup$ @0scar I completely disconnected the BL Touch, reinstalled the Z limit switch, & installed firmware version Ender3-v4.2.7-Stock-20210307.bin from marlin.crc.id.au. The printer now auto home's as expected. Perhaps the BL Touch is wired incorrectly then? $\endgroup$ – wallwalker Mar 7 at 15:06
4
$\begingroup$

Resolved : connected the white & black wires to the 5 pin output on the board. This solved the homing issue.

$\endgroup$
1
  • $\begingroup$ Don't forget to mark your answer as the accepted answer, in order to remove the question from the unanswered question queue. Thanks. $\endgroup$ – Greenonline Jul 12 at 4:53
1
$\begingroup$

I had the same issue and thought I bricked it, so thank you for getting me on the right path! For Ender 3 Pro v4.2.2 motherboard, no Pinboard A, ISP Pinboard, or Burner required! In my case, I had used the provided pins (white housing) that were on the v4.2.2 motherboard itself.

In doing so I had to switch the positions of the red and blue wires in the 3-pin connector (glad I pay attention to those types of things), connected white and black connectors right beside it as the OP has figured out (the connector my BLTouch came with was a little big so I had to cut a wall of the white housing a little; it fits really well), and re-connected the original Z-axis cable (did not need to remove to start with, but still unused as the BLT pretty much replaces it).

$\endgroup$
5
  • $\begingroup$ Welcome to SE.3DP! We're glad to see that you've fixed your problem! However, It may be better to add this as a comment on the answer that helped you, as Answers are only for solutions to the question! $\endgroup$ – craftxbox Jul 10 at 21:39
  • 1
    $\begingroup$ @craftxbox - I think that the answer is a bit too long to put as a comment. Plus we don't want to encourage people leaving comments that look like answers - for a number of reasons: (1) Comments can not be voted upon; (2) Comments should only be for clarification requests, not for holding information (3) Comments are ephemeral in nature and tend to get deleted. It is better that solutions are self contained in one post, and not spread out through comments, as it makes it harder to extract all of the info, if people have to trawl through comments to get the full picture. $\endgroup$ – Greenonline Jul 12 at 5:00
  • 1
    $\begingroup$ @craftxbox - Admittedly, this answer may not be answering the question itself, and may be answering another (as yet unasked) closely related question. It is unclear if Charles's issue was the same as the OP's. Nevertheless, it is a useful and informative answer and may help other people in the future. $\endgroup$ – Greenonline Jul 12 at 5:04
  • 1
    $\begingroup$ HI Charles and welcome to SE.3DP, BTW. :-) $\endgroup$ – Greenonline Jul 12 at 5:04
  • 1
    $\begingroup$ @Greenonline - XD thanks $\endgroup$ – Charles Smith II Jul 12 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.