I have a BLTouch clone (3DTouch) on my printer (Artillery Sidewinder X1). I installed it on the printer ages ago and has been working fine since. Recently, I did a BTT smart filament sensor upgrade.

I updated and edited both the Marlin firmware and the MKS TFT28 screen firmware to get it to work with the smart filament sensor. The filament sensor runs through the screen not the motherboard so it is enabled in screen firmware instead.

The sensor works fine and every other part of the printer is fine as well, except that after the BLTouch does a G29 (I have it do that before every print in my start G-code, followed by an M500), It will not adjust the Z-axis to compensate for the unevenness of the bed. I can see the Z motors not move and I cannot feel the lead screws rotate in my hand if I touch my hand against them.

I have been through several other forums, videos, etc. on the internet but none of them have the same problem as me and/or their solutions do not fix the problems.

I have also tried flashing the display with the original firmware, which did not work so I guess is that I have something wrong with the firmware. I have checked and double-checked my firmware but maybe there is something I missed or do not know about that could be causing my problem.

Firmware can be found here.

I have tried running the original firmware with changes only made to enable the BLTouch. The Z-axis does still not compensate.

I have also replaced the mainboard. I don’t know if that could affect the operation or not.

Recently, I needed to print a part so I put the default Marlin firmware using the Artillery SWX1 example in Marlin's collection of examples with modifications made only to work with the BLTouch. I can post this copy of the firmware but it is probably identical to the GitHub repo below. This way I could just print with no Z compensation, however, now whenever I try to home the printer or do a G29, the BLTouch doesn't deploy and it will crash into the bed. I posted an unlisted video on YouTube demonstrating the issue here. Also note that in the video, I attempt to move the Z-axis by 1 mm, but instead, the stepper motors spin at full speed and the gantry comes zooming towards the bed.

I tried flashing the firmware yet again and for some reason, the BLTouch worked. it could home is and to a probing routine. I have been using the printer without the compensation and it works fine but it is really bizarre that this is happening. I know it is unlikely to solve the problem, but I am thinking of purchasing a replacement BLTouch. They are only 20 bucks to replace and I did accidental slightly bend the plastic probe before the Z stopped compensating. So is it possible the BLTouch is cactus?

I have tried all the answers below.

  • $\begingroup$ Does anybody have an idea of what is wrong? Do I need to add more information? If so please let me know what I should add. $\endgroup$ – HotGlue May 28 at 6:09
  • $\begingroup$ Is the board exactly the same board (type, brand) you replaced the original with? I hope you are aware of the original 1.1.9 Marlin based firmware at github.com/artillery3d/sidewinder-x1-firmware? $\endgroup$ – 0scar Jun 4 at 10:19
  • $\begingroup$ No, the original was MKS Gen L v1.0 , the new one was an MKS Gen L v2.1 . $\endgroup$ – HotGlue Jun 4 at 22:02
  • $\begingroup$ Please try when the new sensor arrived and write a proper answer, you can even accept it after 48 hours. Then you can remove your last edit and incorporate that into the answer. $\endgroup$ – 0scar Jun 26 at 11:48

There is something not correct in your configuration file.

You mention the use of an upgraded controller board from an MKS GEN L to a MKS GEN L v2.1. This change of hardware is not effectively present in your configuration.h file, ik currently States the use of the old board:

// Choose the name from boards.h that matches your setup

You should have used the board constant called BOARD_MKS_GEN_L_V21.

I honestly don't know if this could fix your problem, but at least all correct pins are then loaded and could help you start searching for the problem.


I have the exact same printer and had the same issue using the same probe. What fixed it for me was adding a M420 S1 after G29.

  • $\begingroup$ That should already be active if you look at the G29 G-code sources. But, worth a try I have seen this also on a very old Marlin version happening. $\endgroup$ – 0scar Jun 6 at 7:37

I am not the best with firmware modifications or anything like that, but you could try running your printer through OctoPrint and do the bed leveling through that and maybe that might fix the problem that you are facing.

  • 2
    $\begingroup$ OctoPrint is an interface to the printer controller board, if the board/firmware doesn't work, this won't work either. $\endgroup$ – 0scar Jun 2 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.