I recently upgraded to Simplify3D version 5. With this version, I can now print over WiFi to my Qidi X-Pro. I run an Eero mesh network and the printer is about 6 feet from the router.

I tried printing a model with this version over WiFi and received the following error on the Qidi console:

Illegal gcode in line: xxxx, P_4, T_10470103!

On a second attempt, I received:

Illegal gcode in line xxxx, P_$, T10470000!

The same models print correctly if saved to a USB stick first and then inserted into the printer. I've been in contact with Simplify3d support, but, they can't recreate the problem.

Has anyone encountered this problem? Do you know of a fix?

  • $\begingroup$ My experience with Qidi technical support, via email, has been quite good. It takes a couple of days between exchanges, but they may have some assistance for you. I was able to request and receive an S3D profile for my X-Max. $\endgroup$
    – fred_dot_u
    Mar 13 at 20:32
  • $\begingroup$ Instead of the update, could you please post this as the answer. How strange this answer might sound, it helped you, it might help others too. $\endgroup$
    – 0scar
    Apr 13 at 18:10

1 Answer 1


I ran another test. This time I used the USB device that came with the printer. The print finished without errors. I'm not sure why using a different USB device would impact the WiFi printing.

Note: I have some suspicions that using a quality setting of High may have actually caused the problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .