8
$\begingroup$

I upgraded from Cura 2.7 to 3.1.0 and I'm getting horrible under extrusion, I'm sure this is the software because I rolled back to 2.7 and everything is working fine again.

My printing is a Robo3D R1+ using the "custom FDM printer" profile.

Is there any new setting or a setting that isn't migrated properly that causes this?

$\endgroup$
  • $\begingroup$ Maybe give your custom profile parameter so we can have a guess at what could be wrong ? I don't think someone here has enough divination skills to guess the parameters on your software. $\endgroup$ – Tensibai Dec 21 '17 at 13:09
  • $\begingroup$ This may be a bug, because my new install of latest Cura is creating the same problem AND I saw 2.85 one of the settings, so I changed it to 1.75 and it continued to under extrude severely. All was well with a Repetier print. Now reading above I need to also check both the machine settings and material section of the print settings. $\endgroup$ – SimonSolar2C Jun 30 '19 at 10:45
  • $\begingroup$ This is not a bug, Ultimaker default filament diameter is 2.85 mm, so that is what they default to. $\endgroup$ – 0scar Jun 30 '19 at 12:03
7
$\begingroup$

Some users have reported upgrades to Cura changing the filament size to the default 2.85 mm. If you are using 1.75 mm filament (which most printers do), you will get extreme under-extrusion.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thanks, that was it, the filament diameter was correct in the machine settings (that I checked) but not in the material section of the print settings $\endgroup$ – Nir Dec 21 '17 at 13:42
  • $\begingroup$ Similar issue here but both settings were 1.75. I re-saved printer and material preferences and modified my custom settings and saved them. Now it works! $\endgroup$ – David Lotts Jan 15 '18 at 6:46
5
$\begingroup$

I hit this issue again in January 2019 with CuraEngine 3.6+git. Since support for multiple extruders was added, it now auto-loads a per-extruder settings file that overrides the main settings file and the command line, so -s material_diameter=1.75 on the command line did not help. Given $foo.def.json, it seems to construct the filename %$foo_extruder_0.def.json, and if that does not exist, loads fdmextruder.def.json, which sets material_width to a default of 2.85.

I was able to solve the problem by either patching fdmextruder.def.json, or making a copy of it named to match my printer's settings file, with the 2.85 changed to 1.75.

Update: There should already be extruder files for supported printers, but they're in a different directory, so they won't be found when invoking CuraEngine from the command line unless you've set the CURA_ENGINE_SEARCH_PATH environment variable to include the path they're in. Alternatively you can copy them to the same directory as the main printer json files.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.