7
$\begingroup$

Our library system just put a 3D printer in one of the branches. I have used SketchUp on the library computers for a number of years just to do artsy things. Suddenly, I have the opportunity to actually print something. (I'm really not sure why the libraries have SketchUp installed. But, I have enjoyed using it.)

There is a plug-in available for SketchUp so that it can export STL files. But, the security on the library computers will not allow me to put a file into the SketchUp plug-ins folder. And, the tech guy at the library doesn't think that the IT guys at the library will update all the copies of SketchUp at all the branches just so someone could do 3D printing.

After doing some searching on this website, I found out that I could export a COLLADA / dae file from SketchUp. I would then import that dae file into Blender (The portable version on my flash drive). I could then export it as an STL file. The process appeared to work. I could see my test object in Blender.

I gave the STL file to the branch manager who tried to open it in the Makerbot software so that it could be sent to the printer. But, it gave him a message about the file not being recognized.

I am not familiar with all the details in the importing and exporting processes that are going on. Is there someone out there that can give me some help?

One problem is that, I am using the library computers. I cannot alter them. I can use what portable versions of software are out there, like Blender.

$\endgroup$
  • $\begingroup$ Have you tried installing SketchUp on your flashdrive? There is a free version available $\endgroup$ – tbm0115 Feb 24 '16 at 20:27
  • $\begingroup$ If you are able to, can you post a download link for the stl file? $\endgroup$ – Daniel M. Feb 24 '16 at 22:17
  • $\begingroup$ If they are going to offer 3d printing capability, it seems like there would be a convincing argument for having at least one of their public computers configured to export to it. Perhaps the one physically closest to the printer or the office of whoever accepts files? $\endgroup$ – Chris Stratton May 17 '16 at 12:13
4
$\begingroup$

Here is what I suggest you try. If you have a file that you can view/edit in blender I would export it as both STL and OBJ formats. Then take those files and upload them to Netfabb (https://netfabb.azurewebsites.net/) and get a "repaired" file. Have the library try again with the repaired STL and OBJ files. If this doesn't work try to get the exact error message/dialog that the makerbot software is giving them as well as the version of the software that they are using.

| improve this answer | |
$\endgroup$
  • $\begingroup$ We tried your suggstion.:MakerBot error message reads "This file could not be loaded. It may be an unsupported file format." Netfabb error message reads ""Failed could not load mesh. (invalid .STL file)" $\endgroup$ – user706 Feb 24 '16 at 21:28
  • $\begingroup$ Okay that indicates that it is almost certainly an issue related to the translation of the file. Did you try with an OBJ file as well? I made a quick box in SketchUp, imported into Blender, Exported the STL and then when I imported it into Netfabb, I got the same error. I tried the same process and when I exported an OBJ it was accepted by Netfabb. Try this and let me know what you find. $\endgroup$ – David Maulik Feb 24 '16 at 21:46
  • $\begingroup$ Sounds like Blender's STL output has issues? $\endgroup$ – Ryan Carlyle Feb 24 '16 at 22:08
  • $\begingroup$ @RyanCarlyle I think it may have something to do with the Sketchup -> DAE - > Blender - > STL workflow. I have great success exporting STL files from modified OBJ/STL as well as native blender formats. It just seems like this is one of those weird combination of things that doesn't seem to work right. $\endgroup$ – David Maulik Feb 24 '16 at 22:15
  • 2
    $\begingroup$ It's strange, because an STL is pretty much just a list of triangle vertices with minimal metadata or encoding, and Makerware/Desktop is usually pretty tolerant of typical mesh issues like flipped normals. (It will load them, anyway.) Is blender outputting a binary or ascii STL? Maybe ascii would work if that's not already what it's using? $\endgroup$ – Ryan Carlyle Feb 24 '16 at 22:21
3
$\begingroup$

Makerbot will accept obj files also. Is there an error while importing the obj file? Also you can see errors of your imported file in your makerbot It will be marked in black.

enter image description here

Please make sure your object is a watertight mesh. As I have seen its easy to make a surface model in sketchup. A 3D Printer cannot print something in surface. You can also try importing to netfabb to check if the part has errors in it.

If you want a better modeling software, I suggest you to check out OnShape. Its a cloud based cad software. Its free as well. (10 private files, beyond that everything is public. 100$ per month i think) www.onshape.com

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy