2
$\begingroup$

I have designed this in Blender:

Screenshot

The bottom is a regular n-gon with 0.8mm in height. In Slic3r, I see that the bottom-most layer is not solid:

Screenshot

The green parts (of the first image) are going into that layer, because I wanted to ensure that I don't have air between the bottom and the green parts. Unfortunately they become printed non-solid / empty.

This does not only take extra time for printing, it's also not what I want. What seems to be the bottom here is in fact the top of something and I want it to be a flat surface.

How can I tell Slic3r to recognize overlapping items and generate them in a solid way?

I have already set the infill to 100%, but that doesn't change anything. The Boolean modifier of Blender is also not very helpful. It creates topologies with gaps.

$\endgroup$
4
$\begingroup$

I printed the thing for some layers to see what the printer actually does: Inner ring

There are clearly too many retractions and unretractions.

This can be seen in advance by letting Slic3r show the retractions and unretractions. Slic3r screenshots

Green items

For the green "walls", it became clear that it prints them exactly onto the empty space, so in fact the seem to be floating.

That made it obvious to me: the normals were pointing into the wrong direction. Therefore, Slic3r seems to have interpreted the material side of the green parts inside out. I had the same issue on some other parts as well.

I went to Blender, selected the object(s), chose edit mode and found a function called "Recalculate normals". Since then, the bottom layer is solid.

Also printing time is reduced by half an hour.

Result after recalculating the normals

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ That was my second guess! There are also online tools to check the models, netfabb is such a website. $\endgroup$ – 0scar Nov 29 '18 at 21:24
1
$\begingroup$

Blender is not a preferred program to model solids, it is great though for many other visualizations. Apparently, the green parts are not solid models in your original Blender design, they are most probably surfaces, when you create an STL, the model is not solid, it contains surfaces. All this causes problems for your slicer (the slicer ignores the surfaces and makes an empty hole instead, hence the sliced image). You should look into the options, manuals or fora of Blender to create solid models. Otherwise, use a proper 3D modelling tool for creating solid models.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.