2
$\begingroup$

I have a modified Anet A8 that is supposed to print hydrogels (paper : Ultra-Low-Cost 3D Bioprinting, Kahl M et al. 2019).

For this to work, we do not need any temperature-related settings, however, I cannot seem to understand how to turn them off. If I try to set the extrusion temp to 25-40 °C, somehow the extrusion servo does not move at all.

Probably I need to enable cold extrusion, but when I tried to add the M302 P1 or M302 S0, it does not work. The printer goes in the path determined by the slicer but the syringe does not extrude the gel.

Unfortunately, the paper did not have anything about the exact settings.

Once in the past I managed to run it, however, that was pre-COVID and the G-code files are probably lost due to me having to reinstall my laptop. If I remember correctly the solution then was to just have the hot end hang from the cross-section of the printer(temps were set at 190 °C?), however, I doubt that it is OSHA approved.

Do you have any proper workarounds?

Current G-code :

;TIME:270
;Filament used: 1.61099m
;Layer height: 0.25
;MINX:102.269
;MINY:97.063
;MINZ:0.3
;MAXX:122.736
;MAXY:117.524
;MAXZ:4.8
;Generated with Cura_SteamEngine 4.8.0
M140 S30
M105
M190 S30
M104 S25
M105
M109 S25
M82 ;absolute extrusion mode
G28 ;Home
G1 Z15.0 F2000 ;Move the platform
M302 S0
G92 E0
G92 E0
G1 F1500 E-10
;LAYER_COUNT:19
;LAYER:0
M107
M204 S1000
G0 F6000 X105.03 Y100.305 Z0.3
;TYPE:SKIRT
G1 F1500 E0
G1 F600 X105.246 Y100.082 E0.697
 
$\endgroup$
4
  • $\begingroup$ What board / firmware are you using? Marlin and Klipper, by default, enable the idiotic feature of only allowing the extruder to move above a certain temperature. This can be disable in the firmwares configuration, e.g. github.com/MarlinFirmware/Marlin/blob/2.0.x/Marlin/… $\endgroup$
    – towe
    Jun 25 at 5:03
  • $\begingroup$ Your use of M302 to enable cold extrusion is entirely correct. I do not think the issue is related to this. To verify, you could try running the same G-code with the extruded heated up just as a test. A safer workaround would be to replace the thermistor with a fixed resistor to make the printer think it is always hot, but you shouldn't need to do that as your current G-code should just work. $\endgroup$ Jun 25 at 6:34
  • $\begingroup$ @towe I was suspecting something similar. I am using the factory firmware however the few related clues that I found on the internet were pointing me towards a firmware update as well. I think I'll probably bake something custom and flash it on. $\endgroup$ Jun 26 at 14:42
  • $\begingroup$ @TomvanderZanden, That could be the reason why it worked back a while ago. Indeed I did not try it with 210 or something degrees recently, because I did not want to heat up but try to make it work at normal temperature. I'll get to the labs tomorrow, or the day after, and try it with both heated up, and a new firmware! $\endgroup$ Jun 26 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.