4
$\begingroup$

When I was notified by Cura that 3.5 was out, I looked at the changelog, and I installed the new version. It worked normally for a time, until once when I went to launch it and cura.exe forever sat idle in task manager doing nothing. I reinstalled Cura 3.5 and tried again.

That then worked for some time, maybe another couple days, and then the same thing happened again. Rince and repeat, maybe for a few more cycles. Now, Cura 3.5 doesn't like to do anything even fresh out of the box. Restarting the computer does nothing.

I've looked at the cura.log file in AppData/Roaming/cura and found a peculiar line:

... 2018-10-10 21:49:33,591 - INFO - [MainThread] UM.VersionUpgradeManager._upgradeFile [369]: Upgraded .\fdmextruder+%232_user.inst.cfg to version 4000005. 2018-10-10 21:49:33,605 - DEBUG - [MainThread] UM.Backend.Backend._logSocketState [178]: Socket state changed to Listening 2018-10-10 21:49:33,650 - INFO - [MainThread] UM.Backend.Backend.startEngine [74]: Started engine process: C:\Program Files\Ultimaker Cura 3.5\CuraEngine.exe 2018-10-10 21:49:33,652 - DEBUG - [MainThread] UM.Backend.Backend._backendLog [94]: [Backend] Calling engine with: ['C:\\Program Files\\Ultimaker Cura 3.5\\CuraEngine.exe', 'connect', '127.0.0.1:49674', '-j', 'C:\\Program Files\\Ultimaker Cura 3.5\\resources\\definitions\\fdmprinter.def.json', '']

It looks as if the issue is when the Cura GUI tries to connect to its backend slicing engine. Is my analysis correct? Is this a known issue/is there a known fix?

I'm going to try to report this to Ultimaker if nothing comes up here.

$\endgroup$
  • 2
    $\begingroup$ This should be mentioned at the Ultimaker forums, not here. I have had similar experience with an older version of Ultimaker Cura. Removing the appdata and re-install fixed it for me. Look at this topic. $\endgroup$ – 0scar Oct 11 '18 at 6:01
  • $\begingroup$ Yea... that seems to work. Any word on why the issue exists in the firstplace? $\endgroup$ – ifconfig Oct 11 '18 at 6:22
  • 2
    $\begingroup$ File bug reports. Or, to be precise, first check for existing reports over at Cura, then file. $\endgroup$ – Carl Witthoft Oct 11 '18 at 15:22
  • $\begingroup$ Yea... I'm in talks with NA support now. @0scar's solution worked for a few hours, or as long as I keep the cura window open. $\endgroup$ – ifconfig Oct 11 '18 at 15:39
5
$\begingroup$

Issues like these are not new, I have experienced similar issues (see e.g. this topic, but more can be found) with an installation of an older version. At the moment of writing there is already a reported issue with Ultimaker Cura 3.5.

It is generally best to mention problems with a specific software application at the developers own forum or tech support. This will catch a more specific type of users as well as the developers themselves.

A workaround, but not a definite solution, is to remove the settings (on the Windows platform these files are located in AppData/Roaming/cura) that Ultimaker Cura uses and remove prior installations and do a fresh re-install of 3.5 and see if this works. Just rename the directory to e.g. AppData/Roaming/cura_old, this way you can always go back.

The drawback of this solution is that all material profiles and printer setups are lost as you start completely new. This is not a problem if you have a single printer and no custom materials defined, but in my case it was a lot of work to get all profiles back.

These issues could be related to the profile settings and storage model, which, at the time of the older installations was not very stable. A new material model was required, if that has been replaced is still a question.

| improve this answer | |
$\endgroup$
  • $\begingroup$ A crude solution if there ever was one, but it does work. $\endgroup$ – ifconfig Oct 11 '18 at 6:39
  • $\begingroup$ EDIT: temporarily..... The issue is back, even with clean config files. $\endgroup$ – ifconfig Oct 11 '18 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.