1
$\begingroup$

A couple of weeks ago I have successfully built a 3D Printer and Printed an XYZ Calibration Cube with ABS material at bed temperature 80 °C.

Next Day I tried bed heating at bed temperature 80 °C,

Screen is blank

and it's not heating at all and showing Following error.

Bed Heating Failed Printer Halted Please Reset

Specification board

I use a RAMPS 1.4 running Marlin 1.1.X

Troubleshooting

I searched on Google and tried possible solutions but they are not working.

  1. I changed the thermistor and nothing happened, the old thermistor is also showing the same temperature.
  2. I connected 12V Supply Positive to SMPS (Switched-Mode Power Supply) and Negative to RAMPS 1.4 and not working
  3. I checked the Voltage at heat bed it's showing zero in spite connecting to SMPS

Please let me know how can I fix the problem?

I have blank image after pressing 80 °C

$\endgroup$
5
  • $\begingroup$ I have installed Marlin 1.1.x firmware. When It's powdered it'll display properly but when I select Bed Heating Option It becomes like a shown in the image and after 30 to 50 seconds later it displays message Bed Heating Failed Printer Halted Please Reset Except Bed heating everything working fine $\endgroup$ Feb 4 '19 at 18:47
  • 1
    $\begingroup$ What happens if you set Bed Temp to, say, 40 Degrees C? Does it warm at all before throwing an error? $\endgroup$ Feb 4 '19 at 20:25
  • $\begingroup$ No, Warming. The LCD Temperature won't change at all from Room Temperature i.e 25 Degrees Celcius. $\endgroup$ Feb 5 '19 at 1:56
  • $\begingroup$ Why not attach your PSU directly to the bed, will it warm up? If it does the bed is working then check cables, connectors of the setup. $\endgroup$
    – 0scar
    Feb 5 '19 at 11:00
  • $\begingroup$ When I connect Heated Bed directly to SMPS it's working but when I connect it to RAMPS board it's not working and the screen is becoming blank $\endgroup$ Feb 12 '19 at 7:39
2
$\begingroup$

Check that your heated bed is still working:

  • Measure the resistance of your heated bed. It depends an the power rating of the bed, but 12V beds usually have values <3 Ohms. That's hard to measure for cheap multimeters, but you just need to check that it's not MOhms which would indicate a broken heated bed.
  • Your heated bed could also have a short. That's hard to measure, as <3Ohms are already 'almost a short'. You'll only notice because your bed will not get warm, but the wires, connectors and elements on the RAMPS will get even hotter. Marlin should detect this and switch off after a few seconds.
  • Check your thermistor. Seems you already did that.
  • Check your RAMPS by measuring the voltage on the bed connector while setting the bed to heat up. You should see 12V, at least in the frist few seconds.
$\endgroup$
1
  • $\begingroup$ Heated Bed is working. when I connect directly to 12V SMPS but it's not working when I connect it to RAMPS 1. 4 $\endgroup$ Feb 8 '19 at 1:49
0
$\begingroup$

I've just been reading 3D Printing Failures: 2020 Edition by Sean Arandy and David Feeney -- one of the things they really harp on is that the high current connectors on the RAMPS board for the bed heat are grossly under-rated -- that is, they're connectors rated for about 4-5 A, while the bed needs to draw about twice that to heat a rated power level. Their recommendation is to switch this connector on the RAMPS board for one rated at a minimum of 16 A to ensure it has a safety margin over the most current a 12V bed heater will draw.

If you use an e-reader, you may want to consider downloading this book -- it's only ten dollars for Kindle (also available on Kindle Unlimited), or twenty for a paper copy, and to my eye, it's worth having.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.