3
$\begingroup$

So I know there have been several clicking Extruder threads but have not found any solutions to the one I am having.

Background: I have a custom Prusa like 3d printer fitted with an MKS board (v1.5) and an MK3 Extruder.

The issue: While i can extrude fine when ordering some extrusion, as soon as i start to print an object the extruder just starts "clicking".

What I have tried so far:

  1. Changing motors: I have tried using a new motor which I know it works and the problem persists.
  2. I have adjusted the stepper driver voltages, and the problem persists.
  3. I have changed the PSU and the problem persists.
  4. Changing the whole board: I have changed the whole board with a brand new one and the problem persists.

I am out of options here. So now the only logical explanation is that the both boards (the old and new) have exactly the same problem, i.e. the extruder stepper driver is bad in some way. Yet again, it works fine when simply extruding...

Any help would be much appreciated. Thanks.

$\endgroup$
2
$\begingroup$

There is one reason why extruders "click": the material can't be melted and advanced fast enough.

There are two likely reasons why your extruder works when used manually, but not during a print:

1. The temperature is not hot enough for the speed (volume per second) demanded by the print.

Have you verified that you're using the proper temperature, and that the head is reaching the proper temperature?

2. There is too much resistance on the delivery.

Have you verified that the Z positioning is not too close, causing back pressure and interfering with the deposition?

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi Davo! Thanks for the reply mate. Regarding your comments: 1. The temperature is verified that is the correct one (even measured with a laser thermometer) and 2. I had the same thought so I started the print at a height of 2cm above the printbed! The problem was not solved in either case... $\endgroup$ – Hlias Feb 28 '19 at 21:10
  • 1
    $\begingroup$ Did it help you? If you resolved this issue, please post an answer below, to help others in the future. $\endgroup$ – Davo Feb 28 '19 at 21:11
  • $\begingroup$ It still may be point 1, even if you are at recommended temps. Try cutting your print speed in half. $\endgroup$ – Davo Mar 1 '19 at 12:22
  • 1
    $\begingroup$ @Hliash How do you verify if it is correct, Davo is right, the temperature should match the volumetric flow, this means that it could be higher than what a filament manufacturer puts on the outside of the box. What I mean is that it does not matter what you specify in the slicer, if it clicks you should reduce print speed or decrease the pressure. $\endgroup$ – 0scar Mar 1 '19 at 19:09
  • $\begingroup$ Hi guys! Thanks for the responses. I am now assuming that the only logical explanation for the clicking/vibrating motor problem is cursed! The problem I am getting is not even while printing. It just happens when I try to extrude manually about 3 cm above the printbed. I have changed motors (tried with a fresh new motor and even a second one) and the problem persists. I have changed to a new driver (the second extruder driver E1) and the problem persists. The only solutions i can think of is calling an exorcist or switching to an Arduino/Ramps board.. $\endgroup$ – Hlias Apr 2 '19 at 10:53
2
$\begingroup$

Perhaps the print extrude speed is much higher than the manual extrude speed.

Often times the jog functions presented in printer host software are set to reasonably low speeds, while the actual maximum allowed speed is much higher. If you are using pronterface, there is an option above the jog controls to set the speed. Note it's current value, and raise it until either the extruder clicks as your print does, or until it simple stops increasing speed. If you can make it click with more speed, then your max E speed limit is too high. You can either lower it with M203 in your starting gcode, or reflash the firmware with a new value. Alternatively you could limit the speed in your slicer and trust that it will not exceed the machine's capabilities.

If you cannot make it click with more speed in a manual extrude, then the firmware limits are fine (you can still check them with M503) and the problem is elsewhere. Perhaps the filament getting caught, or a motor wire damaged and making partial contact.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi Silver! Thanks for your comment. I have tried the speeds as you mentioned and I cannot make it click ranging from 300 up to 1200. So yes, apparently the problem is elsewhere. Filament getting caught is not the issue as the extrusion is fine when not printing, motor wire is not damaged as I have already tried 3 different motors. $\endgroup$ – Hlias Mar 1 '19 at 10:54
  • $\begingroup$ 1200 mm/m is not high enough. That is only 20mm/s. Run m503 to see the limit in firmware, and approach that value. $\endgroup$ – silver Mar 1 '19 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.