Hot answers tagged

3

I don't know the probe, but I have used a delta 3D printing machine (of my design) to scan a surface. It takes some time. Your resolution will be limited by the probe geometry of the touch probe tip. You want a Z-probe function that reports the Z-value of the point, not that simply sets Z= when the probe "hits". The RepRap firmware has this in the G30 ...


2

You need to enable the constant Z_SAFE_HOMING (like: #define Z_SAFE_HOMING) in your printer configuration file (if you're using Marlin firmware that is). This will move the nozzle to the middle of the plate prior to lowering the nozzle by default: #if ENABLED(Z_SAFE_HOMING) #define Z_SAFE_HOMING_X_POINT ((X_BED_SIZE) / 2) // X point for Z homing when ...


2

That it triggers when the nozzle is about 1 mm from the build plate is how it is supposed to work. The installation manual describes how to setup the sensor. The mount needs to be adjustable so that the distance between the bottom of the sensor (not the pin) needs to be 8.3mm above the tip of the nozzle. When taking the above distance into account, the ...


2

Considering this is an Ender, it is probably caused by the rollers on the X axis or the un-driven right Z post. I've also seen behavior like this caused by a too constraint PTFE Bowden tube, at the far end the tube pulls on the carriage lifting it slightly upwards, hence a different/larger gap.


2

Ok so I did a bit of testing with the wiring and it turns out I just had the 3DTouch in the Z- socket instead of Z+ :-) . Another idiot mistake from me!


1

Use Z Safe Homing to avoid homing with a Z probe outside the bed area According to Marlin firmware with this feature enabled: Allow Z homing only after X and Y homing AND stepper drivers still enabled. If stepper drivers time out, it will need X and Y homing again before Z homing. Move the Z probe (or nozzle) to a defined XY point before Z Homing when ...


1

So I discovered that the fade height must have been set to something really off. I didn't know this at the time so I thought I should set the fade height to the default 10 mm just to make sure nothing was wrong and tested it. The printer now levels and compensates perfectly!


1

I have the exact same printer and had the same issue using the same probe. What fixed it for me was adding a M420 S1 after G29.


1

There is something not correct in your configuration file. You mention the use of an upgraded controller board from an MKS GEN L to a MKS GEN L v2.1. ...the original was MKS Gen L v1.0 , the new one was an MKS Gen L v2.1... This change of hardware is not effectively present in your configuration.h file, it currently states the use of the old board: // ...


1

I am not the best with firmware modifications or anything like that, but you could try running your printer through OctoPrint and do the bed leveling through that and maybe that might fix the problem that you are facing.


1

After troubleshooting I have managed to fix the sensor problems. (Please take note of the update at the end of the answer below as the problem started again shortly after the so-called fix...) Digging into several posts I found this post that hints to a solution: After readjusting, the sensor worked and I was able to produce a print, but the next day it ...


Only top voted, non community-wiki answers of a minimum length are eligible